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Introduction to PTC Windchill
Quality Solutions

Thank you for your interest in PTC Windchill Quality Solutions®. This
comprehensive toolset represents the next generation in QLM (quality lifecycle
management) software.

With PTC Windchill Quality Solutions, you can predict the reliability and
maintainability of your system, evaluate critical failure modes, model your
complete system to analyze reliability and availability, and perform a wide array
of additional analysis functions.

This guide assumes that you are operating the PTC Windchill Quality Solutions
Tryout version. However, you can also use this guide with a licensed version of
PTC Windchill Quality Solutions.

Once installed, the Tryout version is active for 30 days. When the 30-day trial
period expires, a message box opens when you attempt to start PTC Windchill
Quality Solutions. Please contact us if you are ready to purchase PTC Windchill
Quality Solutions or need further information about your evaluation.

While the Tryout version limits the amount of data you can add to your Projects, it
still enables you to fully explore all of the software’s capabilities. During
operation, if the data limit for a particular data element is reached, a warning
message indicates that no further data can be added.

There are a few important points to take note of when using this guide:

* First, review the sections Getting Started on page 9 and Common Features on
page 23. These sections introduce you to the basic concepts of PTC Windchill
Quality Solutions. Once you have reviewed these sections, you can continue



with any of the module-specific sections or progress step-by-step through each
section.

* You do not have to complete the module-specific sections in any particular
order. However, this guide assumes that, individually, each section is
completed from beginning to end.

* The PTC Windchill Quality Solutions Tryout version is based on the Team
Edition. You can use this guide with the Enterprise Edition as well. Although
there are differences between these two Editions, the majority of the features
and functionality described in the guide are the same. One significant
difference is that in the Enterprise Edition, you are required to log in using a
PTC Windchill Quality Solutions user name and password. It is also possible
that in the Enterprise Edition, some functions described in the guide might be
unavailable to you, depending on permissions set by your system
administrator

*  You can open a PDF version of this guide by selecting Help > Getting Started
Guide. Or, from the Start Page window, you can click the Getting Started
Guide: A Step-by-Step Tutorial link in the Links section. You can print this file

if you prefer a hard copy of the guide.

We hope that you find this guide helpful as an introduction to PTC Windchill
Quality Solutions. Once you are comfortable with the basics, you will find further
details on the wide array of features available by accessing the help, which
provides comprehensive information about all aspects of PTC Windchill Quality
Solutions.

Welcome!
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This section of the PTC Windchill Quality Solutions Getting Started Guide
introduces you to the interface and describes how to work with Projects. You learn
how to start and exit PTC Windchill Quality Solutions. You also learn how to use
the Project Navigator to create new Projects and open and close existing Projects.

~ Note

Because Projects can be fully customized, your screens might not look like the
ones shown in this guide.




Starting PTC Windchill Quality Solutions

You can start PTC Windchill Quality Solutions using either of the standard
Windows® methods:

* Double-click the shortcut to PTC Windchill Quality Solutions 10.2 Tryout on
your Windows desktop.

* From the Windows Start menu, select [All] Programs » PTC Windchill Quality
Solutions 10.2 Tryout » PTC Windchill Quality Solutions 10.2 Tryout.

~ Note

If you are running a licensed version, “Tryout” is not included in the program
name.

Selecting the Modules to Evaluate

Once PTC Windchill Quality Solutions is started, the Modules Selection window
opens, listing all modules available for your use. In the Tryout version, no
modules are selected by default, and you must select at least one module to
continue. Clicking a module button alternates between selecting a module and
clearing the selection. The button background color for all selected modules is
gold.

1. Click Prediction. Make sure that this button is the only one selected.

~ Note

If you are not using the Tryout version, all modules that you have
purchased are available for selection. Click Clear All and then click
Prediction.

2. Click OK to display the Start Page window.

Exiting PTC Windchill Quality Solutions

To exit PTC Windchill Quality Solutions at any time, do one of the following:
» Select File » Exit.

* Click the x button in the top right corner of the application window.
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Start Page Window

The Start Page window is the startup center for PTC Windchill Quality Solutions.
You see this window when you first start the Tryout version or Team Edition. In
the Enterprise Edition, you see this window after you enter valid login account
information.

The appearance of the page that you see can vary. Additionally, the number of
pages that you see can vary. For example, you might see a global page that your
system administrator has assigned to your user group, the default page, and any
number of custom personal pages that you have created. The following sections
provide all of the information you need to put the many advanced features of the
Start page to immediate use:

+ Start Page Controls on page 11
« Start Page Additional Features on page 14

Start Page Controls

A Start page can contain several controls that can help you use PTC Windchill
Quality Solutions more efficiently. Provided below are descriptions of the controls
that are shown on the default Start page that is supplied with PTC Windchill
Quality Solutions.

~ Note

On a global Start page that is assigned to you by your system administrator,
you are likely to see different controls than those described in this section. In
the help or guide for this application, you can find information about
customizing Start pages.

Recent Files

The Recent Files control lists as many as the last 10 files you viewed. When file
names are shown in this control, you can click the name to open the file. In the
Tryout version and Team Edition, the title bar of this control contains a New
Project link. Clicking it opens the Create Project window, allowing you to create a
new Project right from the Start page.

Getting Started 11



Announcements

The Announcements control displays announcements posted by users, providing a
great mechanism for team communication. Each announcement includes a title,
the name of the person who posted the announcement, and the announcement
itself. Announcements marked as “High Priority” have a title that appears in red.

To insert an announcement:
1. Do one of the following to open the Add New Announcement window:

* In the Tryout version or Team Edition, click New on the right side of the
title bar.

* In the Enterprise Edition, select Options » New from the menu on the right
side of the title bar.

The Add New Announcement window opens.
2. For Title, enter A New Announcement.
3. For Message, enter I 've postedmy first announcement.

For Expiration, use the date control for this field to select tomorrow's date. Do
not select the High priority checkbox for this announcement.

5. When finished, click OK to insert your announcement.
To delete an announcement:

1. Right-click the announcement you just inserted and select Delete. A
confirmation window opens.

2. Click OK to delete the announcement.
To modify an existing announcement, you right-click it and select Edit. In the Edit

Announcement window that opens, you modify the announcement and then click
OK to save your changes.

Links

The Links control displays links for quick and easy access to Internet resources.
For example, if you have a website that you visit frequently, you can set up a link
to it. When you click the link, your browser starts and opens the specified web
address in a new window.

Several important links are already listed for you, including:

* Getting Started Guide: A Step-by-Step Tutorial — Opens a PDF version of this
guide. You cannot delete or modify this link.

* PTC Website — Opens the PTC Windchill Quality Solutions page on the PTC
website.

* PTC Technical Support — Opens the Technical Support page on the PTC
website, where you must have a PTC customer account to use the many
support tools provided.

12 Getting Started Guide



To insert a link:
1. Do one of the following to open the Add New Link window:

* In the Tryout version or Team Edition, click New on the right side of the
title bar.

* In the Enterprise Edition, select Options » New from the menu on the right
side of the title bar.

The Add New Link window opens.
2. For Display text, enter Google.
3. For Link, enter www . google . com.

Click OK to insert the link to the Google® website. If you have Internet
access, you can click this link to open this web page in a new window.

To delete a link:

1. Right-click the Google link that you just inserted and select Delete. A
confirmation window opens.
2. Click OK to delete the link.

To modify an existing link, you right-click it and select Edit. In the Edit Link
window that opens, you modify the link and then click OK to save your changes.

~ Note

If you are using the Enterprise Edition, two additional controls appear on the
Start page: Workflow and Alerts.

Workflow

Workflow capabilities allow you to control your process flow by notifying
appropriate personnel when actions are required. By using the Workflow feature,
you can effectively manage your processes to keep your analysis activities on
track.

The Workflow control displays all outstanding workflow items that are assigned to
you. When you click an item, the email message associated with the item opens.
When you click the icon for the associated table type, the corresponding System
file opens, and the corresponding record is selected.

Alerts

The Alert application automatically notifies users when specified events occur. By
monitoring your Project data, this application detects the occurrence of key events
and automatically sends out email alerts.
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Similar to the Workflow control, the Alerts control displays all alerts that have been
sent to you. When you click an alert, the email message associated with the alert
opens. When you click the icon for the associated table type, the corresponding
System file opens, and the associated data is shown.

Start Page Additional Features

The Start page offers several additional features.

Expand/Collapse

In the title bar of a control, an arrow button is available for either collapsing or
expanding the control. In the Tryout version and Team Edition, the arrow button is
on the right. In the Enterprise Edition, the arrow button is on the left. To switch
between collapsing and expanding a control, you click the arrow button.

Menu Bar

The menu bar appears in the upper right corner of the Start Page window. The
following figure displays the menu bar for the Enterprise Edition because it
provides additional options.

O G Logged in as Admin | Change Log-in

* Clicking the about icon @ opens the About PTC Windchill Quality Solutions
window, where you can see copyright information, authorized options (if
licensed), file versions, and data directories. Clicking OK closes this window.

* Clicking the help icon @ opens the help for PTC Windchill Quality Solutions
in a new browser window.

* The Logged in as status, which is available only in the Enterprise Edition,
indicates the user name that you used when you logged in to this session.

* Clicking Change Login, which is available only in the Enterprise Edition,
allows you to change your login to a different user without having to restart
PTC Windchill Quality Solutions.

Customize

In only the Enterprise Edition, a Customize link is shown in the upper right corner
of the page if you have the permissions necessary to insert and customize Start
pages. When you click this link, Content and Layout tabs are shown so you can set
up controls and lay them out on the page.

e |
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To put some of these menu features to use:

1. Click the about icon €?. The About PTC Windchill Quality Solutions window
opens.

A navigation pane appears on the left side of this window. You click a page
name to display this property page in the right pane.

a. On the Copyright page, view the copyright notice for PTC Windchill
Quality Solutions.

b. On the Authorized Options page, view all the licensed modules and
prediction calculation models that you can activate. In an unlicensed
version, the status for these modules and models is blank.

c. On the File Versions page, view the versions of the PTC Windchill Quality

Solutions files in use.

d. On the My Data Directories page, view the locations where your local
Project files, Predication Parts library files, and personal user options are
stored.

e. Click OK to close this window.

2. Click the help icon ©. The help for the desktop application opens in a new
window.

You can use the navigation pane on the left to browse or search help topics.
When you are finished, close this window.

For more information, see “PTC Windchill Quality Solutions Documentation
and Help” in the “Welcome!” section.

Project Navigator
At the heart of PTC Windchill Quality Solutions is the Project Navigator.

Getting Started
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The Project Navigator allows you to easily open and create Projects and files,
generate reports and graphs, create files, and perform many other functions from a
single location.

Project Mavigator -

[Z4 Create new Project
] Create new file
£ Collapse files

Projects
o < Click to close Project > -

=l 25 Project: My Tablet PC
EI[f systems
Tablet PC
B Reports
Ei Graphs
Support Files

¥ My Filter File

The Project Navigator is an auto-hide window. Initially, it is in auto-hide mode. A
tab for sliding this window out into view is located on the left side of the main
window.

PTC" Windchill’ Qual

Joefiaen) oalold

= Recent Files

File Name
Tablet PC

When you place the mouse cursor over this tab, the window slides into view.
When you move the mouse cursor outside of the Project Navigator, or any auto-
hide window operating in the auto-hide mode, the window slides out of view.
Thus, you can easily show the Project Navigator when you need to use it and hide
it when you do not.

You can dock, or pin, an auto-hide window so that it is always available to you.
When you place the mouse cursor over the pushpin icon to pin or unpin it, the
background color of the icon is blue.

To take the Project Navigator out of the auto-hide mode:

1. Place the mouse cursor over the Project Navigator tab to bring the window into
view.

2. Click the horizontally-oriented pushpin icon # in the upper right corner of the
window.

16 Getting Started Guide



The pushpin icon changes to a vertical orientation to indicate that the window
is now pinned into place. This means that the Project Navigator does not slide
out of view when you move the mouse cursor outside of the window. Any
time the pushpin icon of an auto-hide window is shown vertically-oriented, the
window is pinned into place.

3. To unpin the window and put it back into auto-hide mode, click the vertically-

oriented pushpin icon ‘# .

The pushpin icon changes to a horizontal orientation to indicate that the
window is now operating in the auto-hide mode.

You can either keep the Project Navigator in the auto-hide mode, sliding it in or
out of view as needed, or dock it into place in the main window. This guide
assumes that the Project Navigator is operating in the auto-hide mode.

With the exception of the Project Navigator, auto-hide windows can be closed by
clicking the x in the upper right corner of the window.

Working with Projects

Your starting point is the Project. The Project contains the framework in which
you enter data, run calculations, generate reports and graphs, and perform all
analysis tasks.

In some cases, you might want to start with a new Project. In other cases, you
might want to create a Project based on an existing Project.

We begin by creating a Project.

~ Note

If someone has previously run through this guide, the Project My Tablet PC
might be listed in the Project Navigator and/or in the Recent Files control on
the Start page. Before running through the rest of this guide, delete this Project
by right-clicking on the Project name in the Project Navigator and selecting
Delete File. When the confirmation window opens, click Yes. In the Enterprise
Edition, only system administrators can create and delete Projects. If you are
not a system administrator, obtain the name of a Project and System file you
can open from your administrator and see Opening a Project and System File
on page 20.
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Creating a Project from Scratch

Creating a Project from scratch is easy. The following procedure assumes that you
are using the Tryout version and that the Project name that you enter is unique.
For information about all types of Project creation scenarios, see “Creating a
Project” in the guide or help for this application.

To create a Project from scratch:

1.

18

In the Project Navigator, click Create new Project.

Project Mavigator * H

L4 Create new Project

] Create new file
& Collapse files

When the Create Tryout Project window opens, Directory and Name are filled
in.

For Name, enter My New Project.
Select Run New Project Wizard.
Click OK.

The New Project Wizard starts and displays the Select Project Starting Point
page.

Select Create a new Project and click Next. The Select Project Modules page
appears.

You can use the Select All and Clear All buttons to select or clear all
checkboxes. Repeatedly clicking a checkbox switches between selecting and
clearing it.

Click Select All and then click Next. The Set Project Properties page appears.

For this Project, accept the default values and click Next. The Select Common
Library Files page appears.

This page lists all files in the Common Library, which is a special Project
where you keep files that you want to use with Projects that you create. All
supplied Report Design, Report Binder, and Graph Template files are included
in the Common Library by default.

Accept the default values and click Next. The Specify FMEA Setup page
appears.

Accept the default selection of Set up FMEA now and click Next. The Select
FMEA Worksheet Type page appears.

On this page, you select from a list of supplied standard layouts for performing
FMEA (failure mode and effects analysis) tasks
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10. Accept the default selection of FMEA Standard Template and click Next. The
Select FMEA Modes Library page appears.

On this page, you select from a list of supplied FMEA Modes Library files for
performing component FMEAs.

11. Accept the default selection of FMD97 Modes - Tryout and click Next. The Set
FMEA Options page appears.

On this page, you specify whether any local effects that you enter in a FMEA
are to automatically roll up as failure modes at the next level of your FMEA
hierarchy. You also indicate whether to turn on the tables for control plans and
DVPs (design verification plans) in this Project’s default System file.

12. Make sure all checkboxes are cleared so that modes are not rolled up and

tables for control plans and DVP are not turned on. Then, click Next. The
Wizard Complete page appears.

13. Click Finish. Progress indicators appear as the Project is created. Once the
process is completed, the Project’s empty System file opens.

14. Slide the Project Navigator into view. Your newly created Project is now open
and appears in the Project Navigator list. You can see the name of your new

Project in the top Project: heading designated by the open folder icon: My New
Project.

Project Mavigator -

B4 Create new Project
] Create new file
£ Collapse files

Jolefiaep) oalold

Projects

0 < Click to close Project > -

[l 5 Project: My New Project
EI[f systems
My Mew Project

i§ Reports
Eﬂ Graphs
Support Files

¥ My Filter File

The term Project is used to denote the entire entity that encompasses all
analysis files. For example, in the Project Navigator, you can see the following
headings: Systems, Reports, and Graphs. These are some of the types of files
that are contained in your Project.

The first heading, Systems, refers to the main files that contain the data to
analyze. In this case, one System file is listed: My New Project. You can
create additional System file in a Project if desired. In this case, we use only
one.
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The other files in your Project are used to either set up the Project or support
your analysis tasks.

15. Slide the Project Navigator out of view. Because the newly created System file
is empty, no data is displayed in it.

Closing a Project and System File
To close the My New Project Project and System file:
1. Slide the Project Navigator into view.

2. Click < Click to close Project >.

The Project Navigator shows a list of Projects, which includes the supplied special
Common Library Project as well as the new Project that you just created.

Opening a Project and System File
To open the My New Project Project and System file:

1. In the Project Navigator, under My New Project, click My New Project to open
your System file.

2. Once again, close your Project by clicking < Click to close Project > in the
Project Navigator.

Notice that My New Project is now listed in the Recent Files control on the
Start page.

¢ Tip
Clicking a file name in the Recent Files control is another way to open a
Project’s System files.

Creating a Project from an Existing Project

In some cases, you might want to create a Project from an existing Project. The
existing Project can be one you set up yourself, or it can be a supplied template or
sample Project. PTC Windchill Quality Solutions includes several templates and
one sample Project that you can use as a starting point for creating a Project. You
might find that a template creates a Project that is close to what you need,
requiring only minor modifications.

This topic describes how to create a Project based on the Tablet PC Sample
Project. The Project that you create here is then used throughout the remainder of
this guide.
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~ Note

As mentioned earlier, in the Enterprise Edition, only system administrators can
create Projects. If you are a system administrator, create a Project from the
Tablet PC Sample Project and then tell users of this application how they can
open this System file to use it for the remainder of this guide.

1. In the Project Navigator, click Create new Project. The Create Tryout Project
window opens.

2. For Name, enter My Tablet PC.
Select Run New Project Wizard.
Click OK. The New Project Wizard starts and displays the Select Project
Starting Point page.

If a Project with this name is found, a window appears with the message that
the Project already exists. You can either cancel the Project creation or enter a
different name to create the Project.

5. Select Create from a Sample Project and click Next. The Select Project page
appears.

6. Select Tablet PC Sample and click Next. The Wizard Complete page appears.
7. Click Finish.

Progress indicators appear as the Project is created. Once this process is complete,
the newly created Tablet PC System file in the My Tablet PC Project opens.

Module Selections Toolbar

In the procedures in this guide, we make use of the Module Selections toolbar.
This toolbar appears by default in the toolbar area at the top of the window.

OM O A& KOAL R

The Module Selections toolbar allows you to activate and deactivate modules.
Using this toolbar enables you to concentrate on the modules you are actively
working with, making your desktop easier to navigate. For this guide, we activate
one module at a time so that only the panes associated with the module we are
using are shown.

If you clicked only the Prediction button in the Modules Selection window when
you first started PTC Windchill Quality Solutions, only the panes for this module
are shown. In the Module Selections toolbar, buttons for all selected modules are
highlighted.
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1. Click the FTA button A in the toolbar to enable PTC Windchill FTA along
with PTC Windchill Prediction. Tabbed panes for both of these modules are
shown.

2. Click the Prediction button A to remove the PTC Windchill Prediction panes.
You can also hide and show the panes associated with particular modules
using the first button © on the toolbar. The tooltip for this button indicates
that it opens a window for configuring selected modules.

Click this button &

4. In the window, do the following to show only PTC Windchill Prediction
panes:

a. Click Clear All.
b. Click Prediction.
c. Click OK.

Moving On

This section introduced you to some of the introductory features of PTC Windchill
Quality Solutions. You can now explore some of the features common to all of the
modules.
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PTC Windchill Quality Solutions supports a number of features common across
all modules. You can run calculations, view outputs such as graphs or reports,
import information from files, filter for desired data, and customize tables.

Although the functions covered in this section are available across all modules,
they are covered here, rather than in the specific module sections, to avoid the
constant repetition of these common tasks. Instead, this section usesPTC
Windchill Prediction as a starting place for reviewing this functionality.

~ Note

Because Projects can be fully customized, your screens might not look like the
ones shown in this guide.
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Getting Started

If PTC Windchill Quality Solutions is started and the Tablet PC
System file is open

If you are already using PTC Windchill Quality Solutions and your Project with
the Tablet PC System file is open, you can enable the Prediction module. For more
information, see Enabling PTC Windchill Prediction on page 24.

If PTC Windchill Quality Solutions is not started

If PTC Windchill Quality Solutions is not started, then start it. For more
information, see Starting PTC Windchill Quality Solutions on page 10.

If your copy of the Tablet PC System file is not open

The Tablet PC System file in your My Tablet PC Project is used to demonstrate
module features in this guide. If this System file is not open, then open it by doing
one of the following:

+ If'the Recent Files control on the Start Page lists the Tablet PC System file in
the My Tablet PC Project, click this file name to open the file.

 If the Project Navigator shows a listing of your Projects and Systems (you see
a Click a file to open link), click Tablet PC under My Tablet PC to open the
System file.

 If the Project Navigator shows that a different Project is open (you see a name
other than My Tablet PC after the Project: label):
1. Close all open files by clicking < Click to close Project >.
2. Under My Tablet PC, click Tablet PC to open the System file.

» If the Project Navigator has the My Tablet PC Project open (you see Project: My
Tablet PC in the Project Navigator), click Tablet PC under the Systems heading
to open this System file.

Enabling PTC Windchill Prediction

In the Module Selections toolbar, make sure the Prediction button A is selected
and all other module buttons are deselected.

Tour of the Interface

When you open a System file, the tables and forms for the selected modules
appear by default in the upper and lower panes of the main window. When
multiple tables and forms are available in a pane, tabs are shown. To display a
particular table or form, you select its tab.
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When you are only viewing the panes for the Prediction module, the top window
contains two tabs:

System Tree Items — Displays the hierarchical breakdown of your system and
is shared with several other modules.

Problems — Displays a list of problems and is shared with several other
modules.

The tabs shown in the bottom pane depend on whether an assembly or part is
selected in the System Tree Items table. When an assembly is selected, the
following tabs are shown:

Parts Table — Displays all parts for the active assembly in the System Tree
Items table.

General Data — Displays general properties for the assembly.
Calculation Data — Displays calculation properties for the assembly.

Problems Form — Displays a sample form for entering data for the active
problem in the Problems table.

When a part is selected, the following tabs are shown:

Parts Table — Displays all parts for the active assembly in the System Tree
Items table.

Prediction Data — Displays the parameters required for calculating a predicted
failure rate for the part.

General Data — Displays general properties for the part as well as inherited
properties from the parent assembly that you can override.

Problems Form — Displays a sample form for entering data for the active
problem in the Problems table.

Reviewing Data

In the System Tree Items table, select the Motherboard assembly.

If necessary, select Parts Table in the lower pane to make this table active. The
list of parts that make up the Motherboard assembly is shown.

In this table, click Static RAM. The part number for this part is SRAMO31.

Review the fields available in this table. You can see that this part is a memory
device. There are four of these parts on the Motherboard. They are assigned
reference designators of U3 through U6.

Click Prediction Data to view the specific parameters associated with this part.

Click General Data to view the general data associated with this part.
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Running Calculations

To run calculations:

1. Select System » Calculate, or click the calculate button & on the Standard

toolbar. The Calculate window opens.
In the left pane, select Calculation Selection if it is not already selected.

In the right pane, click Clear All and then select Prediction to run calculations
only for the Prediction module.

4. In the left pane, select Prediction.

Leave the default values.

?:. Prediction Calculation Options

[¥] Mission calculations
[T] Allocations
[T Uze alternate MIL-HDBK-217 resistor calculation

Derating calculations: anminaI "]

Mission profile: lDefauIt Profile - ]

6. Click OK to run the calculations. The auto-hide Calculation Progress window

opens and displays status information. When the calculations are complete, the
View Calculation Results window opens.

o Tlp
You can print your calculation results by clicking Print in the View
Calculation Results window. You can also save them to a Microsoft®
Excel® spreadsheet by clicking Excel.

7. Click Close when you have finished reviewing results.

To display the results again at any time, you would select System > View
Calculation Results. If you have only one module enabled, the results shown are
only for this module. If multiple modules are enabled, a navigation pane is shown
so that you can select the pages for the results you want to view.
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Generating Reports

The reporting capabilities within PTC Windchill Quality Solutions are extensive.
They include the ability to view reports, print reports, generate reports to files, and
create custom reports. We begin by viewing a supplied report.

Viewing a Report

1. In the Project Navigator, under Reports > Prediction Reports, select (Common)
Prediction (Summary).

The Generating Report window opens, displaying progress. Once the report is
generated, it opens in a preview window. You can use the toolbar in this
window to print your report, move through its page, switch between a two-
page and one-page view, zoom in and out, and close this window.

2566 6ole

2. When finished viewing the report, do one of the following to close the
window:

¢ Select Preview » Close.

*  Click the close button on the toolbar.

Alternatively, you can view a report by selecting File » Print Preview. In the Select
Report to Preview window that opens, you select the report you want to view and
click OK to generate the report and open it in a preview window.

If you want to override the default properties for a report, when you select the
report, also select the Override report properties checkbox. Before report
generation begins, the Report Properties window opens so that you can specify
custom values for the report.

o Tip

On the standard toolbar, selecting the button for previewing a report also
opens the Select Report to Preview window.

Printing a Report to a Printer

Any time you are viewing a report in a preview window, you can print it by

clicking the print button in this window’s toolbar.
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However, if you want to bypass viewing the report, you can send it directly to a
printer:

1.

From the System file, select File » Print. The Select Report to Print window
opens.

Select the report and click OK. The Print window opens.
Select the printer, supply print properties, and then click OK to print the report.

Tip
On the standard toolbar, selecting the button for printing a report also
opens the Select Report to Print window. If you select the Override report

properties checkbox, before report generations beings, the Report Properties
window opens so that you can custom specify values for the report.

Printing a Report to a File

You can also print a report to a file, which is useful if you want to email reports to
colleagues or save them for later viewing. PTC Windchill Quality Solutions
supports several file formats to which you can save reports.

1.

2
3.
4.
5
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Select File » Print. The Select Report to Print window opens.

Select (Common) Prediction (Summary).

For Print to file, click the browse button E to open the Print to File window.
For File name, enter My Reliability Prediction.

For Save as type, select a file format that you know you can view on your

computer. For example, if you have Adobe® Reader® installed, you can select
PDF Format (*.pdf). If you haveMicrosoft Word® installed, you can select
Microsoft Word Document (*.doc). If you are unsure, select Rich Text Format (*.
rtf).

Ensure that the Open file in editor after printing checkbox is selected.

~ Note

If you do not know if you have any of the applications needed for viewing
the supported file types, you can clear the Open file in editor after printing
checkbox. If this checkbox is selected and the appropriate viewing
application is not installed, the file is created, but it cannot be opened.
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Click Create. The Select Report to Print window becomes active again, with
Print to file now completed appropriately.

Click OK to generate the report and open the saved file in the associated
application.

When you have finished viewing the file, exit the application.

Creating Custom Reports

The Report Wizard enables you to easily create custom reports. This wizard
provides a step-by-step process for walking you through the report creation. Once
you have created a report, you can save it to a Report Design file for later use.

1.
2.

To start, select the Parts Table in the lower pane to make it active.

Select Tools » Report Wizard. The Report Wizard starts and displays the Select
Data Fields page.

Because the Parts Table is active, Prediction Parts is the default selection for
Table type. To make report creation easier, all fields shown in the active table
or form for the report are automatically selected.

To remove Part Classification (Prediction Parts) from the Selected fields list,
select it and then click Remove.
In the same, also remove the following fields: Calculation Model (Prediction

Parts), Tagged Part? (Prediction Parts), and Failure Rate, Percentage
(Prediction Parts).

Make sure the following fields are in the Selected fields list: Name (Prediction
Parts); Part Number (Prediction Parts); Category (Prediction Parts);
Subcategory (Prediction Parts);, Reference Designator (Prediction Parts);
Quantity (Prediction Parts); and Failure Rate, Predicted (Prediction Parts).

Click Next. The Select Filter page appears.

Accept the default of — No Filter — and click Next. The Specify Data Grouping
page appears. Here you can group records into categories.

For example, if you wanted to group records based on Category (Prediction
Parts), your report would show all integrated circuits together in a section, all
resistors together in a section, and so on. For this example, you do not want to
group records in any way.

Leave Selected fields list empty and click Next. The Specify Sort page
appears.

In the first selection box, select Failure Rate, Predicted (Prediction Parts).
Clear the Ascending checkbox so that the failure rate data is sorted in
descending order; then, click Next. The Select Layout page appears.

10. For Layout, select Horizontal.
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11.

12.
13.

14.

15.

16.

17.

For Orientation, select Landscape; then, click Next. The Report Style page
appears.

Select Corporate and click Next. The Report Title page appears.

For Title, enter My Prediction Report; then, click Next. The Wizard
Complete page appears.

Click Finish. The report is generated and opens in a preview window. The
report lists all parts in order of descending failure rate.

You might notice a few items you want to modify in the Report Design. For
example, perhaps you want to rename a column heading to make it more
descriptive or to shorten it.

Also, notice that some columns are wrapping. In this case, you might want to
change the width of these columns. The Report Wizard creates a base Report
Design file that you can then modify to suit your needs. Although you can use
the Report Designer to place data fields directly into a blank Report Design
file that you create, using the Report Wizard to create the base file is far more
efficient. You then only need to make minor adjustments to the resulting file.

Select Preview » Close to close the window. The Report Design file remains
open in the Report Designer.

In the design view, you can see the layout used to generate the report. You can
now modify the Report Design file by adding new data fields, deleting fields,
changing column widths, renaming column labels, and changing the report
heading. You can also change colors, fonts, and other visual properties.
Additionally, you can use more advanced features such as sorting, grouping,
and filtering data. You can even define formulas and insert them in reports.
The Report Designer is extremely powerful, enabling you to completely
customize reports to suit your needs.

At this point, you can choose to save the Report Design file. Let’s assume that
you want to save it.

Do the following to save the file:
a. Select File » Save As. The Save File As window opens.
b. For Name, enter My Prediction Report; then, click OK.

Select File » Close. If you are asked if you want to save your changes, click
No.

Your new Report Design file is now available in the Project Navigator under
Reports > Prediction Reports. To generate this report at any time, you would click
the report name.

If you want to generate multiple reports at one time, you can insert Report Design
files in Report Binders files. For more information about all reporting features and
functions, see the PTC Windchill Quality Solutions help or guide.
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Generating Graphs

PTC Windchill Quality Solutions has an extensive array of impressive graph
capabilities, including the ability to view a predefined graph or create a custom
graph. You begin by viewing one of the supplied predefined graphs.

Viewing a Predefined Graph

1. In the Project Navigator, under Graphs > Prediction Graphs, select (Common)
Prediction FR v Temperature to generate this supplied predefined graph.

This graph displays the predicted failure rate for each assembly in the system
tree for a range of temperatures from 0 to 100 degrees C, in increments of 10.

2. When finished viewing the graph, do one of the following to close the graph.

* Select File » Close.
*  Click the X in the upper right corner of the graph window.

Alternatively, you can view a predefined graph by selecting Tools » Graph. In the
Select Graph Template window that opens, you select the graph to view and then
click OK to generate the graph.

o Tip

On the standard toolbar, selecting the graph button also opens the Select
Graph Template window.

Creating a Custom Graph

The Graph Wizard enables you to easily create custom graphs of your System
data. This wizard walks you through a series of questions about the graph you
want to create. You can save graph settings to a Graph Template file so that you
can quickly recreate this same graph at a later time.

1. Select Tools » Graph Wizard. The Graph Wizard starts and displays the Load
Graph Template page.

2. Select Create a custom graph and click Next. The Prediction Graph Type page
appears.

3. Select Calculation result by System Tree item (uses last calculation result) and
click Next. The Select Calculation page appears.

4. Select Failure Rate, Predicted and click Next. The Filter Data page appears.

5. Select Graph only assemblies and click Next. The Graph Options page appears.
The default type is a cylinder bar graph.
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For Graph title, enter My Prediction Graph.

6
7. Select the Pareto checkbox. Leave all other checkboxes cleared.
8. Click Next. The Save Graph Template page appears.

9

To save the settings to a Graph Template file, do the following:

a. For File name, click the browse button [-]. A window opens, listing all
existing Graph Template files.

b. Click < Create new file > and enter My Prediction Graph.

c. Click the green checkmark [4]

d. Make sure that the Create corresponding Report Design file checkbox is
cleared.

10. Click Next. The Wizard Complete page appears.
11. Click Finish to generate the graph.

The resulting graph shows the assemblies in your system ordered by overall
failure rate. From this graph, you can see which assemblies contribute the
most to overall system failure rate.

Modifying the Graph
You can modify the properties of any graph that has been generated.

1. In the window containing the graph, select View » Properties. The Graph
Properties window opens.

2. In the navigation pane on the left, select the various pages available to view
the many properties that you can modify.

3. When finished, click Cancel to close the window.
Select File » Close.

5. Ifyou are asked if you want to save your changes, click No.

Filtering Data

When viewing your System data, you might want to view a subset of items in your
Project. With large quantities of data, filtering techniques enable you to display
only those items that are of interest to you. Filters can be applied not only for
viewing purposes but also prior to running calculations and generating reports and
graphs.

Filters enable you to view items matching a certain parameter or multiple
parameters, find a specific item or set of items based on a parameter entered “on
the fly,” and even sort items. It is helpful to experiment with the filtering features.
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PTC Windchill Quality Solutions supports both fixed-value filters and
parameterized filters. When you create a parameterized filter, you must supply a
parameter value when the filter is applied. You can also build filters with multiple
parameters. When building a parameterized filter, be aware that the request for a
parameter value occurs whenever the filter is used, even during report or graph
generation.

Using Predefined Filters

PTC Windchill Quality Solutions includes a number of predefined filters that you
can apply.

1. Inthe System Tree Items table, select Motherboard.

2. Select the Parts Table. The list of parts in the Motherboard assembly are
shown.

3. In the toolbar, use the filter selection box to select Reference Designator.

¢ Tip
If you do not see Reference Designator in the filter list, ensure that you
have the Parts Table selected. The filters available in the list depend on the
active pane or window.

¥ - Mo Filter - -

-- Mo Filter -

Alternate Part Number
I
*.Part Mumber
*Ref‘erence Designator

The Select Filter window opens. Because this filter is a parameterized filter,
you must supply a parameter value before the filter can be applied.

4. For Reference Designator is equal to, enter U8 and click OK.

Only the item with the matching reference designator is now shown in the

Parts Table. If you place the mouse cursor over the filter icon ¥ inthe upper
left corner of the Parts Table, parameters for the filter are shown as a tooltip.

Parts Table

Fiter B = [ = B = M = &

%{-" Mame Part Murmber | Part Classification | Category
{|reference Designator iz equal to 'u8' And Parent Assembly is equal to 'MBOG0415' E

5. In the filter selection box, select — No Filter — to remove the applied filter.
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Creating Custom Filters

You can create custom filters for ad hoc queries. To create a custom filter:

1.
2.

10.
I1.
12.

13.
14.
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Select the Parts Table.

Select Filter » Filter Wizard. The Filter Wizard starts and displays the Specify
Filter Features page.

Select Selects records only and click Next. The Specify Filter Field page
appears.

For Select the table type, select Prediction Parts.

From the list of data fields, select Temperature Rise and click Next. The
Specify Condition page appears.

Select is greater than or equal to and click Next. The Specify Field Value page
appears.

Select Use a fixed value (specify the value below).

For Specify the value for ‘Temperature Rise (Prediction Parts)’ here, enter 20
as the temperature rise value and click Next. The Review Filter page appears.

Leave | want to add more conditions to the filter clear, to indicate that the filter
is complete, and click Next. The Save Filter page appears.

Select | want to save my filter for later use.
For Filter name, enter Prediction - High Temperature Parts.
Select Save filter to My Filter File.

You have the option of saving filters to two different locations.

* If you select Save filter to My Filter File, your new filter is stored in a file
accessible only to you. The filter is not accessible to other users with filter
permissions.

» If you select Save filter to the Filter File in this Project, the filter is
accessible to other users with filter permissions.

In some cases, you might be creating a filter that is for your own use. In that
case, it is best to save it to your My Filter file. In other cases, if you are
creating a filter you know would be helpful to all team members, you would
want to save it to the Project Filter file so others can use it.

Click Next. The Wizard Complete page appears.
Click Finish.

If this is the first time you have saved a personal filter, PTC Windchill Quality
Solutions asks if you want to create a My Filter file in which to store your
newly constructed filter. In the Create Support File window, click Yes to create

this file.
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If you have previously created a My Filter file, this message does not appear.
If a message appears asking if you want to overwrite or use the existing file,
select Use Existing.

The filter is applied to your data so that all parts with a temperature rise of 20
degrees Celsius or higher are shown. Your new filter is shown in the filter
selection box.

In the list for this selection box, your new filter, Prediction - High Temperature
Parts, is preceded with a person icon instead of an asterisk icon. This indicates
that the filter is stored in your My Filter file and not in the Project Filter file.
All Project filters are preceded with a folder icon.

15. To return to the original data view, select — No Filter — in this selection box.

You can also view and modify filters in Filter files. Open the Project Filter file by
selecting Filter under Support Files > Setup in the Project Navigator. You can
insert new filters directly in this file. Similarly, Support Files > Setup in the
Project Navigator, you can click My Filter file to open your personal Filter file to
view, modify, and insert personal filters in it.

Lastly, you can use the filter bar to quickly build filters. The filter bar is located
above the column headers if a table supports it. You can use the filter bar to sort
records and/or select the data to be shown in the table. You can also save filters
created using the filter bar by clicking the save icon © in the top left corner of the
filter bar.

Partg Table
FiI ==
¥ Name
1 |Micrn:-prn:u:ess::nr |

Customizing Tables

Virtually all tables in the System file can be customized using the Format Builder,
which enables you to easily change the fields shown in tables.

For this example, you modify the layout of the Parts Table.

1. Right-click the Parts Table and select Format Builder. The Format Builder
opens and displays all of the fields available for insertion in the table. The
checkboxes to the left of the fields indicate which fields are shown in the table
as columns. If the checkbox is cleared, the field is not shown.

2. Select the 217 Quality checkbox. The Parts Table is updated to include this
field as the last column. If you cannot see the last column, use the scroll bar to
view it.
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3. Now, clear the 217 Quality checkbox to remove this field.

4.

Close the Format Builder.

The Format Builder inserts fields at the end of the table. However, you can click
and drag a column to where you want it.

Importing Data

The Import Wizard enables you to easily import data into your System file by
asking you a series of questions about the data you want to copy in to it. You can
save the settings for performing an import in an Import/Export Template file so
that you can quickly perform this same import later.

For this example, you import data into a new System file.

I.

36

Under Navigator Tasks in the Project Navigator, click Create new file. The
Create File window opens. The Project field is automatically filled in with the

current Project.

For File type, select System. For Name, enter My Imported Data. Make
sure the Run Create File Wizard checkbox is cleared. Click OK to create and
open the new System file.

Select Tools » Import Wizard. The Import Wizard starts and displays the Load
Template page.

Select Perform a custom import and click Next. The Select Source File page
appears.

For Source file name, click the browse button IZI The Open window opens.

For Files of type, sclect Microsoft Excel.

Navigate to the My Tablet PC folder in your My PTC Windchill
Quality Solutions Files directory.

~ Note

If you are using the Enterprise Edition, you must navigate to the Samples
directory on the application server and then open the folder for your
installed language. You then open the Tablet PC Sample folder, where
the file referenced in the next step resides.

Select ReliabilityPredictionimport and click Open.

You are returned to the Select Source File page, where the path to the selected
file is shown.

Click Next. The Specify Worksheet Format page appears.
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10.

I1.
12.

13.

14.

15.
16.

17.

18.

19.

20.

Leave First row of cells has column names selected and click Next. The Select
Data Type page appears.

Select Parts only and click Next. The Select Import Type page appears.

Select | want to add records and click Next. The Select Field Assignments page
appears.

On this page, you map the data to import into PTC Windchill Quality
Solutions fields. The first column is selected by default.

Map the columns for the data to import:

a. For Data field, which appears near the bottom of the page, select Part
Number.

The column heading of the first column changes to Part Number.

To map a column to a field, you can either select from the Data field list or
type letters for the field name until the correct match is located.

b. Click the second column and, for Data field, select Quantity.
c. Click the third column and, for Data field, select Reference Designator.
d. Click the fourth column and, for Data field, select Name.

Now that all four columns are mapped, click Next. The Save Template page
appears.

For this example, you do not need to save your import settings to an Import/
Export Template file.

Click Next. The Wizard Complete page appears.

Click Finish. Importing begins and the Parent Assembly Selection window
opens.

Select System as the parent assembly and select Do not ask me this again. Use
the current selections as the default.

This lets the Import Wizard know the parent assembly with which to associate
imported parts.

Click OK to continue the import. When the import is complete, the Import/
Export window shows “Import completed.”

If errors or warnings occur during your imports, you can click View Log to see
them. In this case, there are no errors or warnings, and all parts are imported
successfully.

Click Close to dismiss the Import/Export window. You can see the newly
imported parts in the Parts Table and System Tree Items table.

When you are finished reviewing your new data, select File » Close.

For this example, you are going to delete the newly created System file.
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21. In the Project Navigator, right-click the System file named My Imported Data
and select Delete.

22. When the confirmation window opens, click Yes to delete the file.

Moving On

While the introductory sections introduced you to some basic features, PTC
Windchill Quality Solutions offers an extensive array of additional capabilities.
With the foundation you now have, you can move forward to explore specific
analysis modules. All module-specific sections assume that you have successfully
completed the introductory sections and are comfortable with the features they
describe.

At any time during operation, help is available. To access the help, do one of the
following:

* Click the help icon @ on the Start Page.
* Sclect Help » Help.
» Press the F1 key to display context-sensitive help.
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PTC Windchill Prediction

Reliability Prediction OVEIVIEW ...........oooiiiiiii e 40
Getting Started with PTC Windchill Prediction...............cooiii e 40
Using PTC WiIndchill PrediCtion ... 41
Understanding Prediction Calculations.............oooui i 45
Viewing a Prediction RePOIt .........oooiiiii e 48
Graphing Prediction Data........ ... 48
Additional Prediction FEatures...... ... 49

This section of the PTC Windchill Quality Solutions Getting Started Guide
provides basic information about reliability predictions and how to perform this
type of analysis using PTC Windchill Prediction. In this section, you learn how to
enter data, run calculations, and view outputs such as reports and graphs.

>~ Note

Because Projects can be fully customized, your screens might not look like the
ones shown in this guide.
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Reliability Prediction Overview

Reliability prediction is a quantitative analysis technique used to predict the
failure rate of a system based on the components of the system and its operating
conditions. A reliability prediction is typically performed using an accepted,
published handbook, which defines failure rate equations for various components
used in the system design. These equations were developed by using statistical
techniques to analyze failure data gathered on actual operating equipment. The
equations take into account various parameters, such as part quality and operating
stresses, which have an effect on component reliability.

To begin a reliability prediction analysis, you must first define your system and all
of its component parts. You then use the model equations to determine the failure
rate of each particular component in your system. To get the overall system failure
rate, you add up all the component failure rates.

For example, consider a system that is comprised of subsystem A and subsystem
B. Assume subsystem A has 5 parts, each of which has a predicted failure rate of 1
failure/million hours obtained from using failure rate equations from a selected
handbook. Assume subsystem B has 5 parts, each of which has a failure rate of 3
failures/million hours, computed using the same handbook. The failure rate of
subsystem A is 5 failures/million hours and the failure rate of subsystem B is 15
failures/million hours. Thus, the failure rate of the overall system is 20 failures/
million hours.

Doing this analysis by hand can be tedious, time-consuming, and error prone.
Using a software application such as PTC Windchill Prediction to perform this
work can dramatically increase the efficiency and accuracy of analyses.

If you are unfamiliar with reliability prediction analysis and would like to study
this topic in more detail, the following selections are excellent references:

» Reliability: A Practitioner's guide (Chapter 3)

» Practical Reliability Engineering by Patrick D.T. O'Connor, 4th edition, John
Wiley & Sons Ltd. (2002)

» The specific reliability prediction handbook of interest to you. For details, see
“Ordering Reliability Standards” in the help.

Getting Started with PTC Windchill
Prediction

If PTC Windchill Quality Solutions is started and the Tablet PC
System file is open

If you are already using PTC Windchill Quality Solutions and your Project with
the Tablet PC System file is open, you can enable the Prediction module. For more
information, see Enabling PTC Windchill Prediction on page 41.
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If PTC Windchill Quality Solutions is not started
If PTC Windchill Quality Solutions is not started, then start it. For more
information, see Starting PTC Windchill Quality Solutions on page 10.

If your copy of the Tablet PC System file is not open

The Tablet PC System file in your My Tablet PC Project is used to demonstrate
module features in this guide. If this System file is not open, then open it by doing
one of the following:

» Ifthe Recent Files control on the Start Page lists the Tablet PC System file in
the My Tablet PC Project, click this file name to open the file.

 If the Project Navigator shows a listing of your Projects and Systems (you see
a Click a file to open link), click Tablet PC under My Tablet PC to open the
System file.

 If the Project Navigator shows that a different Project is open (you see a name
other than My Tablet PC after the Project: label):

1. Close all open files by clicking < Click to close Project >.
2. Under My Tablet PC, click Tablet PC to open the System file.

» If the Project Navigator has the My Tablet PC Project open (you see Project: My
Tablet PC in the Project Navigator), click Tablet PC under the Systems heading
to open this System file.

Enabling PTC Windchill Prediction

On the Module Selections toolbar at the top right of the window, make sure the
Prediction button A is selected and all other module buttons are deselected.

The System file displays only PTC Windchill Prediction panes

Using PTC Windchill Prediction

In the top pane, the System Tree Items table displays the hierarchical breakdown
of your system. In the bottom pane, the Parts Table displays all components in the
assembly selected in the system tree. In the bottom pane, the additional tabbed
panes shown depend on whether an assembly or part is active.

When an assembly is selected in the System Tree Items table, the General Data
pane displays general information about the selected assembly, and the Calculation
Data pane displays calculation parameters for the selected assembly. When a part
is selected in the System Tree Items table or Parts Table, the Prediction Data pane
displays calculation parameters for the selected part, and the General Data pane
displays general information about the selected part.
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Viewing Prediction Data

1.
2.

In the System Tree Items table, select the Motherboard assembly.

In the Parts Table, which now shows the parts that make up the Motherboard
assembly, click Static RAM.

This part has a part number of SRAMO31.

Review the fields available in this table.

You can see that this is a memory device. There are four of these parts on the
Motherboard.

In the Prediction Data pane, view the parameters associated with this part.

Click Pi Factors to open the Pi Factors window.

In this window, you can see the factors used in the equation for computing the
failure rate for this part. You can also see the failure rate of the part. For
information about how these factors are computed, as well as the failure rate
equations, see the help.

Click Close to close the Pi Factors window.

Entering Assemblies and Parts

Perform the following steps to enter a new assembly and its parts:

1.
2.
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In the System Tree Items table, select Hard Disk Assembly .

Select Insert » Sibling Assembly. A new assembly is inserted at the same level
as the selected assembly.

If you had inserted a child assembly, it would have been inserted one level
lower than the selected assembly.

For Name, enter My Demo Assembly for the new assembly.

In the Parts Table, which currently shows no parts for this newly inserted
assembly, do the following in the blank row:

a. For Name, leave it blank.

For Part Number, enter ABC and press Tab.

The first time that you enter a part number, all enabled Prediction Parts
Libraries are initialized for searching. If you are using a licensed version,
this might take a moment or so.

c. Ifnot already selected, for Part Classification, select General.
d. For Category, select Integrated Circuit.
e. For Subcategory, select Logic, CGA or ASIC.
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f. For Reference Designator, enter U27.

Select the Prediction Data pane.

All part parameters are blank or show one or more number signs (#). To
compute a failure rate, default values are stored for required parameters.
Click Defaults.

A number of parameters are now filled in with values. These values represent

average values for these parameters. The calculation engine uses these average
values if you do not enter specific data values.

Because PTC Windchill Prediction uses average values for the part to produce
a preliminary failure rate estimate, using these default values is a good way to
start your analysis. As data becomes available, you can go back and enter it in
the Prediction Data pane.

Click Defaults again to hide the default values from view.

The Defaults button is there only for informational purposes. During
calculations, PTC Windchill Prediction automatically uses the default values
for parameters in which you do not enter values. You do not need to click
Defaults to have this occur.

Click Pi Factors to see the computed failure rate of your newly inserted part.

Click Close to close the Pi Factors window.

Using Prediction Parts Libraries

A much more efficient way of entering parts is to use the extensive Prediction
Parts Libraries supplied with the Prediction module. These component databases
include hundreds of thousands of parts, along with the associated data needed for
performing reliability prediction analysis.

1.
2.

Select the Parts Table.

In the empty row at the end of the table, for Part Number, enter 741.S00 and
press Tab.

The Prediction module searches through the Prediction Parts Libraries and
automatically fills in the appropriate part data.

Select the Prediction Data tab to view the data that has been automatically
entered for this library part.

You can see that almost all of the parameters have been filled in.

A few fields, such as Initial Temp Rise, are dependent on the operating conditions
of your system. You must enter these types of values.
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Viewing Parts in Parts Library Files

In some cases, you might not know an exact part number. In these cases, you can
browse the parts in Prediction Parts Library files to select the part to insert.

1.
2.

Select the Parts Table.

Right-click the table row with the asterisk (*) and select Browse Libraries. The
Library Browse window opens.

Leave Search for set to Prediction Parts.
For Part Number, enter 74HCT* and click Search.

All parts that begin with 74HCT are shown in the Results table.
In the Results table, scroll down to locate 74HCT373.
Click this row to see the associated part parameter values in the Preview pane.

In the menu for the Results table, click the + Insert button to insert the part in
the Parts Table, which is visible on the right.

u Tip
You can also drag and drop parts from the Library Browse window to insert
them in the Parts Table. Click the desired part’s row in the Results table
and, while still holding down the left mouse button, drag the part to insert
it at the end of the Parts Table.

Searching for Library Parts

1.

In the Search pane of the Library Browse window, for Part Number, clear the
field.

For Description, enter *transistor* and click Search.
The Results table lists all parts that include the text “transistor” in any part of

the Description field. As you can see, you can perform a wide variety of
searches using all types of search parameters.

Entering Parts Using the NPRD/EPRD Libraries

PTC Windchill Prediction also includes libraries of failure rates based on collected
field information for a number of electro-mechanical parts. This data is stored in
databases known as the NPRD and EPRD libraries. To search the data in these
libraries:
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In the Library Browse window, for Search for, select NPRD 2011 Parts.

For Category, select Battery

For Subcategory, select General.

Click Search. The Results table displays the matches for a general battery in

the NPRD 2011 library.
Click NPRD-611 to select it.

In the menu for the Results table, click + Insert to insert the part in the Parts

Table.

7. Close the Library Browse window by clicking the x in the upper right corner of

the window.

Understanding Prediction Calculations

PTC Windchill Prediction calculates a number of metrics, including failure rate,
MTRBEF, reliability, availability, and MTTR, which are briefly described below. For
more information, see the help.

Calculation

Description

Failure Rate

In a reliability prediction analysis, failure rate is a value
that represents the number of failures likely to occur
over a time period, usually defined in units of FPMH
(failure per million hours) or FITS (failures per billion
hours). For example, if a unit has a failure rate of 2
FPMH, that unit is likely to fail twice in a million
hours. Failure rates are predictive values computed
using equations based on statistical field data analysis.

MTBF

The MTBF (mean time between failures) represents the
number of hours a unit operates between failures. For
non-repairable units, which cannot be repaired once a
failure occurs, the MTBEF is equivalent to MTTF (mean
time to first failure). Therefore, the terms MTBF and
MTTF are sometimes used interchangeably, although
doing this is not theoretically accurate. In PTC
Windchill Prediction, the term MTBF is used.

Reliability

The probability that a system remains operational until
a specified time. Reliability is a time-based probability
value, so it is always a metric between 0 and 1. A
reliability of 0 means that a system is infinitely
unreliable, or never functioning. A reliability value of 1
indicates that a system is infinitely reliable, or always
operating.

PTC Windchill Prediction
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Calculation Description

Availability The probability that a system is operating properly at a
specific time point. Availability, like reliability, is a
time-based probability metric between 0 and 1.
Availability is a function of both reliability (how
quickly a system fails) and of maintainability (how
quickly the system can be repaired). The common term
"five nines" refers to a system that has an availability of
0.99999, which means that it is operational 99.999% of
the time.

MTTR MTTR (mean time to repair) is the average time it takes
to repair a failed unit and return it to an operational
state, based on the average repair time for its
replaceable components. The MTTR is calculated by
rolling up the average repair times for lower-level
components to subassembly and system repair values. If
PTC Windchill Maintainability is used in conjunction
with PTC Windchill Prediction, the computed MTTR
values of components and subassemblies can be
obtained from the Maintainability module. Units for
MTTR values are typically hours or minutes. MTTR is
also referred to as MCT (mean corrective time).

PTC Windchill Prediction can also compute the above measures using mission
phases. To perform mission calculations, you define a mission profile, which
describes the phases of a mission your system experiences. For example, the
mission of an airplane might consist of three phases: take-off, flight, and landing.
Each one of these phases occurs in different environments and conditions. You
can also define a phase as dormant or active to factor in the lower failure rates
experienced during dormant phases.

The Prediction module performs mission-based calculations by factoring in the
environment, temperature, state (dormant or active), and percentage of time in
each phase. You can view the results for the entire mission as well as for
individual phases.

PTC Windchill Prediction supports derating analysis as part of prediction
calculations. Derating analyses allow you to assess which components in your
system are overstressed. You can use the results of derating analyses to ensure
your system components are operating within acceptable limits.

The Prediction module also supports a variety of reliability allocation
methodologies. When using these methods, you allot MTBF values across the
subassemblies and/or components of your system, and then, based on specified
weighting factors, calculate the projected failure rate of the components and/or
subassemblies in the system.
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Reliability allocations are useful when you have reliability goals that must be met.
For example, if contractual requirements dictate that your overall system MTBF
must be at least 10,000 hours, you can split up that 10,000-hour goal across the
various items in your system based on a weighting system of your choosing.
Perhaps you assign one highly complex subsystem an MTBF of 5,000 hours, and
split up the remaining 5,000 hours over all other subsystems. In this way, you can
apportion MTBF goals to ensure that your overall objectives are met.

Running Prediction Calculations

To compute the predicted failure rate of your system:

1.

Select System » Calculate, or click the calculate button & on the standard

toolbar. The Calculate window opens.

In the left pane, select the Calculation Selection page if it is not already
selected.

In the right pane, click Clear All and then select Prediction to run only
calculations for the Prediction module.

In the left pane, select the Prediction page.
Leave the default selections.

?:. Prediction Calculation Options

[#] Mission calculations
[ allocations
[[|Use alternate MIL-HDBK-217 resistor calculation

Derating calculations: anminaI "J

Mission profile: lDefauIt Profile - ]

Click OK to run the calculations. The Calculation Progress window opens,
displaying status information. When the calculations are complete, the View
Calculation Results window opens.

= Tlp
You can print your calculation results by clicking Print in the View

Calculation Results window. You can also save them to a Microsoft Excel
spreadsheet by clicking Excel.

Click Close when you have finished reviewing results.
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To display the results again at any time, you would select System » View
Calculation Results. If you have only one module enabled, the results shown are
only for this module. If multiple modules are enabled, a navigation pane is shown
so that you can select the pages for the results you want to view.

Viewing a Prediction Report

1. In the Project Navigator, under Reports > Prediction Reports, select (Common)
Prediction (Summary) to generate this report and open it in a preview window

This report includes assembly names, part numbers, reference designators,
quantities, and calculation results for failure rate and MTBF.

You can use the toolbar in this window to print your report, move through its
page, switch between a two-page and one-page view, zoom in and out, and
close this window.

2. When finished viewing the report, do one of the following to close the
window:

* Select Preview » Close.

*  Click the close button on the toolbar.

Alternatively, you can view a report by selecting File » Print Preview. In the Select
Report to Preview window that opens, you select the report to view.

u Tip

On the standard toolbar, selecting the button for previewing a report also
opens the Select Report to Preview window.

Graphing Prediction Data

1. In the Project Navigator, under Graphs > Prediction Graphs, select (Common)
Prediction FR v Temperature to generate this supplied graph.

This graph displays the predicted failure rate for each assembly in the system
tree for a range of temperatures from 0 to 100 degrees C, in increments of 10.

2. When finished viewing the graph, do one of the following to close the graph.

* Select File » Close.

* Click the X in the upper right corner of the window.
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Alternatively, you can view a predefined graph by selecting Tools » Graph. In the
Select Graph Template window that opens, you select the graph to view and then
click OK to generate the graph.

Tip

On the standard toolbar, selecting the button for generating a graph also
opens the Select Graph Template window.

Additional Prediction Features

Many more features and functions are available within PTC Windchill Prediction.
A brief listing of other topics of interest is shown below. To learn more about
these features, see the help.

PTC Windchill Prediction

You can perform reliability predictions using current prediction standards,
including MIL-HDBK-217, Telcordia, PRISM, 217Plus, HRDS5, RDF 2000,
IEC TR 62380, NSWC Mechanical, Chinese 299, Siemens SN 29500, and
FIDES.

You can combine models within a Project and apply MTBF adjustment
techniques such as PRISM Process Grades and Telcordia calculation methods
for high-powered analyses.

You can use Prediction Derating files to store minimum and maximum
derating criteria for part types.

You can use Prediction Defaults files to store part parameter values for part
types.

You can use Prediction Values Library files to store your own user-defined
environments and quality levels.

You can use Mission Profile files to store data associated with various mission
phases, including dormancy information and the total mission time.

You can use Prediction Parts Library files to store part data for custom parts,
thereby supplementing the supplied Prediction Parts Library files.

You can use Prediction Correlation Library files to search library components
based on in-house part numbers rather than manufacturer part numbers.

You can use Prediction Process Grade files to store scoring profiles, which
translate total scores into quantitative Pi-factor multipliers that impact
predicted failure rates.

You can use Prediction Bayesian files to store test and field data that you want
to use to modify predicted failure rates for more real-world predicted values.
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This section of the PTC Windchill Quality Solutions Getting Started Guide
provides basic information about a FMEA (failure modes and effects analysis) and
how to perform this type of analysis using PTC Windchill FMEA. In this section,
you enter FMEA data, run calculations, and view reports and graphs.

~ Note
Because Projects can be fully customized, your screens might not look like the
ones shown in this guide.
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FMEA Overview

A FMEA consists of breaking a system down into what can fail, how it can fail,
and why it fails, and then determining the effects of those failures on your system.
FMEAs can also include the analysis of criticality, and in this case, they are
referred to as FMECAs (failure mode, effects, and criticality analysis).

FMEAs are typically performed based on published standards or guidelines.
However, some organizations develop their own FMEA guidelines. The most
common FMEA standards include MIL-STD-1629, various automotive standards,
and SAE ARP5580.

The FMEA process is a bottom-up approach to system analysis. The analyst
begins at the lowest level desired for analysis, such as a part or a step in a process,
and ascertains the possible failure modes associated with this item. The next step
is to establish, based on system knowledge, what the resulting effects of failure
modes are. Along with each end effect, the analyst might determine the severity of
this effect, its probability of occurrence, and how it could be detected.

This process continues up the system tree until overall system end effects are
evaluated. Once this detailed analysis is complete, some type of ranking criteria is
employed. The ranking is then used to determine how critical failures can be
eliminated or the risks mitigated. The main objective of a FMEA is to evaluate all
parts of your system or process to ensure that system reliability and safety
objectives are met.

If you are unfamiliar with FMEAs and FMECAs and would like to learn more, the
following selections are excellent references:

» Reliability: A Practitioner's guide (Chapter 6)

* Failure Mode and Effect Analysis - FMEA from Theory to Execution by D.H.
Stamatis

» Failure Modes & Effects Analysis by Paul Palady

Getting Started with PTC Windchill FMEA

If PTC Windchill Quality Solutions is started and the Tablet PC
System file is open

If you are already using PTC Windchill Quality Solutions and the Tablet PC
System file is open, you can get started by activating the FMEA module. For more
information, see Activating PTC Windchill FMEA on page 53.

If PTC Windchill Quality Solutions is not started

If PTC Windchill Quality Solutions is not started, then start it. For more
information, see Starting PTC Windchill Quality Solutions on page 10.
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If your copy of the Tablet PC System file is not open

The Tablet PC System file in your My Tablet PC Project is used to demonstrate
module features in this guide. If this System file is not open, then open it by doing
one of the following:

» If the Recent Files control on the Start Page lists the Tablet PC System file in
the My Tablet PC Project, click this file name to open the file.

+ If the Project Navigator shows a listing of your Projects and Systems (you see
a Click a file to open link), click Tablet PC under My Tablet PC to open the
System file.

» If the Project Navigator shows that a different Project is open (you see a name
other than My Tablet PC after the Project: label):

1. Close all open files by clicking < Click to close Project >.
2. Under My Tablet PC, click Tablet PC to open the System file.

» If the Project Navigator has the My Tablet PC Project open (you see Project: My
Tablet PC in the Project Navigator), click Tablet PC under the Systems heading
to open this System file.

Activating PTC Windchill FMEA

oo
On the Module Selections toolbar, select the FMEA button and deselect all
other module buttons.

The System file displays only PTC Windchill FMEA panes.

Using PTC Windchill FMEA

The top window contains the following tabbed panes:

* System Tree Items — Displays the hierarchical breakdown of your system and
is shared with several other modules.

* Problems — Displays a list of problems and is shared with several other
modules.

* FMEATable — Displays a list of all your FMEAs.

* FMEATree Items — Displays the hierarchical breakdown of your FMEA
structure. By default, the name of the FMEA Tree Items table is followed by a
hyphen and Functional, Process, or Component to indicate the type of FMEA
selected in the FMEA Table.

The bottom window contains the following tabbed panes:
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*  Problems Form — Displays a sample form for entering data about the active
problem in the Problems table.

* FMEA Worksheet — Displays the failure item, mode, cause, and effect data
that is entered for the active FMEA Tree Items record.

* FMEA Control Plans — Displays the control plans inserted in this System file
and FMEA Worksheet causes and FMEA Tree Items records with which they
are associated.

* FMEA DVPs — Displays the DVPs (design verification plans) inserted in this
System file and the FMEA Tree Items records and FMEA Worksheet causes
with which they are associated.

* FMEA — Displays a sample form for entering item, mode, cause, and effect
data for the active FMEA Tree Items record.

In PTC Windchill FMEA, FMEAs can be extensively customized. You can select
which data fields appear and give them custom names. You can also change the
appearance of FMEA cells, adding in fonts, colors, notes, and checkmarks. As a
result, your FMEAs might not look exactly like the ones in this guide.

Additionally, you can perform FMEA activities on the web using PTC Windchill
Quality Solutions Web Access.

Types of FMEAs

FMEAs can basically be classified into one of three possible types: process,
functional, or component. All three of these FMEA types assess the impact of
failures on system performance and safety to determine which failure modes
require efforts to prevent, mitigate, or detect occurrence. The selection of a
particular FMEA type indicates the intended scope of the analysis.

For example, you might choose to limit your assessment of possible failures to
those that can occur during the manufacturing or assembly process of a product.
Or, you might choose to limit it to failures that prevent you from meeting the
functional requirements for a product design. When a comprehensive assessment
of a product design is required, you would not want to limit your assessment in
any manner but rather consider all possible failure modes for all system
components.

The advantage of PTC Windchill FMEA is that it supports any type of FMEA you
want to perform. Additionally, if you have your own hybrid type of FMEA, or
some customized FMEA format, the FMEA module can be adapted to meet your
needs.

For the examples in this guide, we discuss and show the most common types
employed: process, functional, and component. The following sections briefly
discuss these types.
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Process FMEA

A process FMEA examines the ways that failures in a manufacturing or assembly
process can affect the operation and quality of a product or service. A process
FMEA can be performed at any level to evaluate possible failure modes in the
process and limitations in equipment, tooling, gauges, or operator training. The
information collected can help to determine what can be done to prevent potential
failures prior to the first production run. You can then take actions to reduce your
exposure to risks deemed unacceptable.

Functional FMEA

A functional FMEA examines the intended functions that a product, process, or
service is to perform rather than the characteristics of the specific implementation.
When a functional FMEA is developed, a functional block diagram is typically
used to identify the top-level failures for each block in the diagram. For example,
a functional FMEA would consider that a capacitor is intended to regulate voltage
and then analyze the effects of the capacitor failing to regulate voltage. It would
not analyze what would occur if the capacitor fails open or fails shorted.

Component FMEA

A component FMEA examines the characteristics of a specific implementation to
ensure that the design complies with requirements for failures that can cause loss
of end-item function, single-point failures, and fault detection and isolation. Once
individual items of a system are identified in the later design and development
phases, component FMEASs can assess the causes and effects of failure modes on
the lowest-level system items. Component FMEAs for hardware, commonly
referred to as piece-part FMEAs, are the most common type.

Reviewing Types of FMEAs

To review the three types of FMEAs:

1. In the FMEA Table, select System Functional FMEA.

2. Inthe FMEA Tree ltems - Functional table, select Processing Section.

3. In the FMEA Worksheet table, view the functional FMEA for the processing
section of the tablet PC.

4. Inthe FMEA Tree Items - Functional table, select Touchpanel.

In the FMEA Worksheet table, view the functional FMEA for the touchpanel
section of the tablet PC.

In the FMEA Table, select Battery Process FMEA.

In the FMEA Tree Items - Process table, expand Battery if necessary and then
select Solder.
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8. In the FMEA Worksheet table, view the process FMEA for soldering the
battery for the tablet PC.

9. Inthe FMEA Tree ltems - Process table, select Assembly.

10. In the FMEA Worksheet table, view the process FMEA for assembling the
battery of the tablet PC.

11. In the FMEA Table, select Tablet PC Component FMEA.

12. In the FMEA Tree Items - System pane, expand Industrial Tablet PC if
necessary and then select Motherboard.

13. In the FMEA Worksheet table, view the component FMEA for the motherboard
of the tablet PC.

Entering FMEA Data
To enter data in a FMEA:
1. Inthe FMEA Table, sclect System Functional FMEA.

2. Inthe FMEA Tree ltems - Functional table, select Processing Section.

3. In the FMEA Worksheet table, in the Function / Process column, select
Transfer data and provide computing functions.

4. Do the following to insert and complete a new record:
a. Select Insert » Insert Mode to insert a new failure mode.
b. For Failure Mode, enter Hard drive failure.
c. For Mode Percentage, enter 25.
d

For the other three failure modes for this function, change Mode
Percentage to 25.

~ Note
If the entire column is not visible, you can resize the column.

Failure mode percentages of all failure modes for a single item should add
up to 100 percent. For this example, you are going to assume that all four
modes have an equal likelihood of occurring.

In real-world situations, some modes are more likely to occur than others.
You would reflect this by designating the appropriate percentages for each
mode.

e. For Local Effect for your newly inserted failure mode, enter Hard drive
cannot be accessed and press Tab.
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The Add List Item window opens. Because the local effect you just entered
is new, you are being asked whether to add it to the list of possible effects
for this FMEA.

A significant advantage of keeping a list of effects in FMEA is to ensure
consistency. The next time a failure results in “Hard drive cannot be
accessed,” you would not need to type in this effect again because you
could select it from the list.

Click Yes to add the new effect to the list.
For End Effect, select Tablet PC not functional.

For Sev, which is a custom prompt assigned to the Severity field, select 9
to indicate a high severity.

For Class, leave it blank.
For Cause of Failure, enter Bad sector on hard drive.

For Occ, which is a custom prompt assigned to the Occurrence field, select
2 to indicate a low probability of occurrence.

For Current Controls, enter Test hard drive on bootup.

For Det, which is a custom prompt assigned to the Detection field, select 6
to indicate a moderate detection mechanism is in place. Then, press Tab to
move to the next field.

PTC Windchill FMEA automatically computes the RPN (risk priority
number) for this failure mode.

Depending on your system and your requirements, you might need to
determine the RPN values that represent high, medium, and low risk.
Failure modes identified to be high risk should be further analyzed to
determine if controls can be established to eliminate or mitigate the risk of
their occurrence.

For Recommended Actions, enter Add periodic hard drive tests
during normal operation.

For Responsibility, enter Anthony — HD Engr.

2y
4

For Target Date, click in the field to make the calendar icon
Then, click this icon to display the calendar control.

available.

Select one month from today for the target completion date.

Once the recommended actions have been put into place, you would complete the
remaining fields: Actions Taken, Sev Res, Occ Res, and Det Res. These last three
fields all have custom prompts assigned to fields for assigning result values for
severity, occurrence, and detection.

PTC Windchill FMEA
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You have now completed entering data for a new failure mode. Entry of additional
FMEA data is accomplished in the same manner. You can enter any number of
data levels (items, modes, causes, and effects) by using commands on the Insert
menu and on the right-click menu. You can also enable the Insert FMEA Items
toolbar to insert FMEA data using toolbar buttons.

FMEA data structures can be customized, which means you can vary the
hierarchical relationship of your FMEA data as well as the data to collect.

Working with List Library Files

List Library files allow you to define list items that are used throughout your
System file, which ensures that your data is consistent and organized. The sample
Project you are using contains a List Library file.

1. In the Project Navigator, click Expand files to display support files.

~ Note

If this command is not available, click Collapse files and then click Expand
files.

2. Under Support Files > Setup > List Library, select List Library to open it.

In the List Definition table, select the following lists to view their
corresponding list choices in the List Choices table: Location, Local Effect, and
Manufacturers.

4. When finished, select File » Close.

5. In the Project Navigator, click Collapse files to hide all support files.

As you saw while editing the System file in the My Tablet PC Project, in the
Local Effect column in the FMEA Worksheet table, you can select a choice from a
list. You can also type an entirely new local effect directly in the cell. In this case,
a window opens, asking if you want to add this new item to the List Library file.

You see how using List Library files can ensure that you and all team members
use the same wording consistently.

Understanding FMEA Calculations

FMEA calculations are designed to help you determine what failures in your
system need to be addressed and, after a redesign to address critical failures, how
much those changes have affected the overall risk of failure in your system.

The following table describes the results calculated by the FMEA module. Once
calculations run, you can view these results in the FMEA Worksheet table.
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Calculation

Description

RPN

The overall risk of a particular failure mode occurring in
your system. The RPN (risk priority number) 1s
calculated as:

Severity * Occurrence * Detection

Where:
» Severity is an assigned value that indicates the
severity of the effect of a particular failure mode.

* Occurrence is an assigned value that designates how
frequently that particular failure mode is likely to
occur.

* Detection is an assigned value that indicates how
often that particular failure mode can be detected.

While RPN values are computed automatically as you
enter severity, occurrence, and detection values, they are
computed again when you perform FMEA calculations
to ensure that all RPN values are current.

RPN result

An RPN value calculated after design changes are
implemented to address failure modes with high RPNs.
The RPN result is calculated as:

Severity Results * Occurrence Results * Detection
Results

RPN improvement

The percentage of improvement between the original

percentage RPN (before any corrective actions have been taken)
and the RPN result (after corrective actions have been
taken).

Criticality rank A value that provides an assessment of the failure

mode’s severity and probability of occurrence. A failure
mode with a rank of 1 is the most severe with the
highest likelihood of occurring. The result is a
categorized breakdown of failure modes based on risk.
This approach is described in the SAE FMEA 5580
document.

Item failure rate

The number of failures of a specific item over a time
period, usually defined in units of FPMH (failures per
million hours) or FITS (failures per billion hours).

Mode failure rate

The number of occurrences of a specific failure mode
over a time period, usually defined in units of FPMH
(failures per million hours) or FITS (failures per billion
hours).

PTC Windchill FMEA
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Calculation Description

Mode criticality How critical the failure mode is under a particular
severity classification. This criticality value is calculated
as described in MIL-STD-1629, Procedures for
Performing a Failure Mode, Effects and Criticality
Analysis:

Mode Failure Rate * Mode Operating Time * Failure
Effect Probability

Where:

* Mode Failure Rate is a value representing the
number of occurrences of a specific failure mode
over a time period.

*  Mode Operating Time is the duration of applicable
mission phase(s), usually expressed in hours or
number of operating cycles.

» Failure Effect Probability is the probability that the
failure occurs.
Detection percentage | The probability that the failure mode is detected.

Detection failure rate | A value representing the number of detectable
occurrences of a failure mode over a time period,
usually defined in units of detectable failures per million
hours or detectable failures per billion hours.

Isolation percentage The percentage of probability that the failure mode can
be attributed to a specific part.

Isolation failure rate A value representing the number of occurrences of a
failure mode over a time period that can be attributed to
a specific part, usually defined in units of isolation
failures per million hours or isolation failures per billion
hours.

Running FMEA Calculations
To compute FMEA results:

1. Select System » Calculate, or click the calculate button ] on the standard

toolbar. The Calculate window appears.

2. In the left pane, select the Calculation Selection page if it is not already
selected.

3. In the right pane, click Clear All and then select FMEA to run calculations only
for the FMEA module.
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4. In the left pane, expand the FMEA folder if necessary and select the Mission

Phase page.

On this page, you supply mission profile and mission phase options for
mission calculations. For this example, you do not need to consider mission
phases. Leave the default values.

)

Mission Phase Calculation Options

Mission profile; | Default Profile - |

Mission phase; [Ignure Phases "]

In the left pane, select the Risk page.

On this page, you indicate whether to calculate initial and resulting risk levels.
For this example, select both checkboxes.

Click OK to run the calculations. The Calculation Progress window opens,
displaying status information. When the calculations are complete, a window
opens, indicating this.

7. Click OK to close this window.

Viewing a FMEA Report

To view a supplied FMEA report:

1.

In the Project Navigator, under Reports > FMEA Reports, select (Common)
FMEA Standard Design. Because a record selection is required for report

generation, the Report Properties window opens
Under the Record selection heading, select System Functional FMEA.

Click OK to generate the report and open it in a preview window. You can use
the toolbar in this window to print your report, move through its page, switch
between a two-page and one-page view, zoom in and out, and close this
window.

When finished viewing the report, do one of the following to close the
window:

* Select Preview » Close.

*  Click the close button on the toolbar.
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Graphing FMEA Data

The FMEA module has several supplied graphs and supports the creation of
custom graphs. During the installation of PTC Windchill Quality Solutions, Graph
Template files for all supplied graphs are copied into the Common Library so that
they are available for immediate use with all your Projects. You can generate a
graph using any Graph Template file in the Project or in the Common Library. All
Graph Template files in the Common Library have a (Common) prefix in their
names.

To generate a supplied FMEA graph:

1. In the Project Navigator, under Graphs > FMEA Graphs, select (Common)
FMEA Top 10 RPN. The Select FMEA window opens.

2. Select System Functional FMEA and click OK to generate the graph.

This graph displays the failures modes with the highest RPN (risk priority
number) values in a cylinder bar graph.

3. When you are finished viewing the graph, select File » Close. If a window
opens, asking whether you want to save changes, click No.

Additional FMEA Features

PTC Windchill FMEA supports many more features and functions. A brief listing
of other topics of interest is shown below. For more information, see the help and
guides for PTC Windchill Quality Solutions or PTC Windchill Quality Solutions
Web Access.

*  You can use PTC Windchill Quality Solutions Web Access to perform
component, functional, and process FMEAs across the Web. This zero-client,
web-based interface provides a rich Windows-like user interface, enabling
FMEA analysts to move between the desktop and web versions with ease.
PTC Windchill Quality Solutions Web Access provides significant advantages
for enabling FMEAs to be performed in a collaborative environment through
its global accessibility.

* You can use the unique “Roll Up” and “Build” features to construct FMEAs
more effectively. You can either roll up local effects as failure modes for the
next higher data level in the worksheet or build a FMEA by progressing down
through data levels to fill in end effects, next effects, severities, and failure
effect probabilities.

*  You can compute any number of custom FMEA calculations and even
override built-in RPN calculations with custom equations.

* You can customize your FMEA data hierarchy in the Project’s FMEA Design
file, which provides ultimate flexibility to ensure your FMEA process needs
are met.
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*  You can use FMEA Modes Library files to automatically add failure modes for
specific part types to component FMEAs.

* You can use the Project’s FMEA Fault Equivalence file to ensure consistency
and efficiency in FMEA construction. By grouping failure consequences based
on failure modes, this file reduces the level of effort needed to complete a
component FMEA by automatically pulling in consequence data for
duplicated failure modes. PTC Windchill FMEA supplies a number of
standard FMEA Modes Library files.

* You can use control plans to create a structured plan for designing, selecting,
and implementing controls for the system, thereby ensuring that the process
remains in a state of control throughout the product life cycle.

*  You can use DVPs (design verification plans) to track the tests that ensure
product designs are meeting customer specifications and that product
development is correctly focused.

* You can copy PTC Windchill global attributes and PTC Creo quality-critical
characteristics for PTC Windchill parts into the Global Attributes table. In this
special System Tree Items subtable, you can associate attributes with FMEA
control plans and DVPs.
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This section of the PTC Windchill Quality Solutions Getting Started Guide
provides basic information about FTA (fault tree analysis) and how to build and
evaluate fault trees using PTC Windchill FTA. In this section, you enter fault tree
data, run calculations on the data, and view outputs such as reports and graphs.

>~ Note

Because Projects can be fully customized, your screens might not look like the
ones shown in this guide.
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Fault Tree Analysis (FTA) Overview

FTA is an event-oriented analysis technique, which means that it allows for the
consideration of hardware failures and other undesirable events, such as software
failures, human errors, operation and maintenance errors, and environmental
influences. It offers a simple and powerful approach for reliability and safety
analysis. FTA is a deductive, top-down approach that begins with a single event to
be analyzed, usually an undesirable or catastrophic failure, and then aids in the
process of determining the specific causes that can lead to the occurrence of this
event.

FTA is based on a simple set of rules and logic symbols (such as AND gates, OR
gates, and many others) from probability theory and Boolean algebra. It consists
of generating a logic model that allows for both qualitative and quantitative
evaluation of system reliability or availability.

A fault tree is a pictorial representation of the events that could lead to an
undesired event in the system. From a qualitative perspective, you can generate
minimal cut sets, which are the smallest sets of events, such that if they all occur,
cause the undesired top-level event to occur. From a quantitative perspective, you
can determine the likelihood of occurrence of the top event and any intermediate
events given the necessary probabilities of the contributing lower-level events.

If you are unfamiliar with FTA and would like to learn morel, the following
selections are excellent references:

» Reliability: A Practitioner's guide (Chapter 5)

» Fault Tree Analysis Application guide from the Reliability Information
Analysis Center

» Fault Tree Handbook, NUREG-0492, from the U.S. Nuclear Regulatory
Commission

Getting Started with PTC Windchill FTA

If PTC Windchill Quality Solutions is started and the Tablet PC
System file is open

If you are already using PTC Windchill Quality Solutions and your Project with
the Tablet PC System file is open, you can enable the FTA module. For more
information, see Enabling PTC Windchill FTA on page 67.

If PTC Windchill Quality Solutions is not started

If PTC Windchill Quality Solutions is not started, then start it. For more
information, see Starting PTC Windchill Quality Solutions on page 10.
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If your copy of the Tablet PC System file is not open

The Tablet PC System file in your My Tablet PC Project is used to demonstrate
module features in this guide. If this System file is not open, then open it by doing
one of the following:

» If the Recent Files control on the Start Page lists the Tablet PC System file in
the My Tablet PC Project, click this file name to open the file.

+ If the Project Navigator shows a listing of your Projects and Systems (you see
a Click a file to open link), click Tablet PC under My Tablet PC to open the
System file.

» If the Project Navigator shows that a different Project is open (you see a name
other than My Tablet PC after the Project: label):
1. Close all open files by clicking < Click to close Project >.
2. Under My Tablet PC, click Tablet PC to open the System file.

» If the Project Navigator has the My Tablet PC Project open (you see Project: My
Tablet PC in the Project Navigator), click Tablet PC under the Systems heading
to open this System file.

Enabling PTC Windchill FTA

On the Module Selections toolbar, select the FTA button A and deselect all other
module buttons.

The System file displays only PTC Windchill FTA panes.

Using PTC Windchill FTA

The two PTC Windchill FTA panes display the same information about your fault
tree, but in different formats.

The top pane contains the following information:
* Problems — Displays a list of problems and is shared with several other
modules.

* FTATable — Displays an hierarchical table with columns of data. It provides
an expandable/collapsible view of the fault tree data contained in the graphical
view in the lower pane.

The bottom pane contains the following information:

* Problems Form — Displays a sample form for entering data about the active
problem in the Problems table.

* FTA Diagram — Displays a graphical view of the fault tree, which is the most
common view for developing and modifying fault trees. The top figure in the
diagram is referred to as the top event. This is the primary event that the fault
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tree is built around. Shown below the top event is a set of gates and events.
The events, either alone or in combination, cause the top event to occur. You
can double-click a gate or event to view and edit its properties.

Reviewing Gate and Event Properties

All gates and events have properties associated with them. You can edit the
properties of a gate or event by double-clicking it. Or, you can right-click it and
select Properties. To review these properties:

1. In the FTA Diagram, double-click TS-1, which is a basic event with a
description of Temperature Sensor Failure. The Properties window opens.

2. In the left pane, click the following pages to review properties on the various
pages.
* General — Displays the event type and identifying text.

* Calculation Data — Displays information about the event’s quantitative
properties that is used during fault tree calculations.

* Library Event — Displays information about the library associated with
this event. In this case, no information is shown as this event was not
inserted from a library.

* Graphic — Enables you to associate a graphic image of your choosing
with the event.

* User Properties — Provides extra data fields you can use for any purpose
you desire.

* Remarks — Allows you to enter a lengthy notation about this particular
event.

Click Cancel to close the Properties window.

Double-click BAT-FIRE, which is an OR gate with a description of Battery
catches on fire. This gate is the fault tree’s top gate. The Properties window

opens.

Gates have four additional property pages: Inputs, Cut Sets, Reliability
Importance Measures, and FTA Results.

The Inputs page provides a table view of all the events and gates that are
inputs to this gate. The last three pages display calculation results. If
calculations have not yet been run, no data appears on these pages.

5. Click Cancel to close the Properties window.

68 Getting Started Guide



Inserting a New Fault Tree

For this example, you create a new fault tree to model the failure of the hard drive
of the tablet PC.

1.

A

Select Insert » New Top Gate. A new fault tree diagram opens and shows a
new top gate.

In the FTA Diagram, double-click the new gate to open the Properties window.
In the left pane, select the General page.

For Identifier, enter HD Failure.

For Description, enter Hard drive not functioning.

Click OK.

Inserting and Editing Individual Gates and Events

To insert and edit gates or events one at a time:

1.

2.
3.
4

In the FTA Diagram, select the HD Failure OR gate that you just inserted.
Right-click this gate and select Insert Input. The Insert Input window opens.
Select OR Gate as the input type and click OK to insert the gate.

Do the following to define this gate’s properties:

Double-click the gate to open the Properties window.

Select the General page.

For Identifier, enter Mech Fault.

e o o P

For Description, enter Mechanical failure.

e. Click OK to close the Properties window.

Select the HD Failure OR gate again.

Right-click this gate and select Insert Input; then, insert another OR gate.
Do the following to define this gate’s properties:

a. Double-click the gate to open the Properties window.

b. Select the General page.

c. For Identifier, enter Elec/SW Fault.

d. For Description, enter Electrical or software failure.

e. Click OK to close the Properties window.

Select the HD Failure OR gate again.

Right-click this gate and select Insert Input; then, insert yet another OR gate.

a. Double-click the gate to open the Properties window.

b. Select the General page.
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c. For Identifier, enter Ext Fault.
d. For Description, enter External failure.

e. Click OK to close the Properties window.

Inserting Multiple Gates or Events

To insert multiple gates or events:

1.
2.

In the FTA Diagram, select the Mech Fault OR gate.

Select Insert » Event. The Insert Event window opens.

The default input type is Basic Event.

Click OK to insert a basic event.

The mouse cursor changes shape to show the type of gate or event you are
inserting. In this case, it is the circle icon, which indicates a basic event. Also
shown is a plug icon.

*  When a red warning symbol appears over the plug icon, you cannot insert
the event in the current location.

&

*  When no warning symbol appears over the plug icon, you can insert the
event in the current location.

&

Move the cursor so that the circle shape is over the gate labeled Mech Fault.
Because you can insert the basic event in this location, the warning symbol
does not appear over the plug.

Click to insert the basic event. The cursor retains the shape of the basic event
S0 you can continue to insert basic events.

Click to insert one more basic event under the Mech Fault OR gate.

Move the mouse over to the Elec/SW Fault OR gate and insert a single basic
event.

Right-click to exit the insertion mode. The mouse cursor returns to its normal
shape.

Changing an Event to a Gate

At times, you might need to change an event to a gate or a gate to an event. For
this example, assume that rather than completing the logic for the Ext Fault OR
gate at this time, you want to change it to an undeveloped event, indicating that
you will come back later and more fully analyze this particular failure path. This
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type of failure can be caused by such events as the tablet PC being dropped, or
someone spilling coffee on it. For now, however, you want to leave this branch
open-ended and return to develop it later, when you have more information.

1. Inthe FTA Diagram, double-click the Ext Fault Gate. The Properties window
for this gate open.

For Gate/Event Type, select Undeveloped Event.

For Identifier, enter External Fault.

For Description, External failure - Undeveloped.
Click OK.

A

Editing Event Properties

All gates and events have properties associated with them. You can edit the
properties of a gate or event by double-clicking it or by right-clicking it and
selecting Properties from the menu. To view these properties:

1. In the FTA Diagram, beneath the Mech Fault OR gate, double-click the left
event you inserted to open the Event Properties window.

2. On the General page, do the following:

a. For Identifier, enter Bearing Fault.

b. For Description, enter Mechanical bearing failure.
3. On the Calculation Data page, do the following:

a. For Input Type, leave it set to Constant probability.

b. For Probability, enter 0. 0015.

Click OK to close the Event Properties window.

In the FTA Diagram, beneath the Mech Fault OR gate, double-click the second
event you inserted to open the Event Properties window.

6. On the General page, do the following:
a. For Identifier, enter Media Fault.
b. For Description, enter Hard drive media failure.

7. On the Calculation Data page, do the following.

a. For Input Type, select Failure rate/MTBF.
b. For Failure rate, enter 0. 0001.
Click OK to close the Event Properties window.

In the FTA Diagram, beneath the Elec/SW Fault OR gate, double-click the
event you inserted to open the Event Properties window.

10. On the General page, do the following:
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a. For Identifier, enter Controller Fault.
b. For Description, enter Hard drive controller failure.

11. On the Calculation Data page, do the following:

a. For Input Type, leave it set to Constant probability.
b. For Probability, enter 0.0125.
12. Click OK to close the Event Properties window.

13. In the FTA Diagram, double-click the External Fault undeveloped event to open
the Event Properties window.

14. On the Calculation Data page, do the following:

a. For Input Type, leave it set to Constant probability.
b. For Probability, enter 0. 0002.
15. Click OK to close the Event Properties window.

Using Transfer Gates

Fault trees can become quite large and complex, containing many gates and
events. In these cases, for ease of analysis, it might be helpful to break the single
fault tree up into smaller fault trees that are all linked together. Additionally, you
might want to repeat the same logic in two different places.

In both of these cases, a type of gate called a transfer gate is very useful. Transfer
gates are not associated with any logic operation themselves, but they enable you
to break up fault trees for visual reasons or to handle repeated logic.

1. In the FTA Diagram, select the Mech Fault OR gate.
2. Right-click the gate and select Break into Transfer.

A new fault tree is inserted. The Mech Fault OR gate is the top gate, and all of
its lower inputs are intact. The triangular symbol shown with this top gate
indicates that it is part of another fault tree.

3. To return to the original fault tree, right-click the top gate of the new fault tree
and select Transfer » HD Failure. In the original fault tree, a Mech Fault
Transfer gate has replaced the Mech Fault OR gate.

You can bring the newly created Mech Fault fault tree back into its original
location in the main fault tree.

4. Right-click the new Mech Fault Transfer gate and select Transfer » To Mech
Fault to go back to the Mech Fault tree.

5. In this fault tree, right-click the Mech Fault OR gate and select Collapse
Transfer to return the fault tree to the original diagram.
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You can also insert new Transfer gates directly into your fault trees just like any
other gate.

Understanding FTA Calculations

PTC Windchill FTA includes both qualitative and quantitative calculations.
Qualitative calculations analyze the unwanted event (the top gate in the fault tree)
and determine the minimum combination of events that cause this event to occur.
These calculations are useful for identifying unexpected root cause combinations,
designing for weak points in a system, and finding common causes for an issue.
Quantitative calculations measure the unreliability and unavailability of the
system based on the fault tree, and provide a more precise and less subjective
evaluation of a fault tree.

A sampling of supported calculations is outlined below and brief descriptions are
provided. For more information, see the help or guide for PTC Windchill Quality
Solutions.

Calculation Description

Minimal cut sets A cut set identifies which unique combination of
component failures and/or events can cause an
undesired event to occur. A minimal cut set is the
smallest set of events, which, if they all occur, cause
the top event to occur.

Reliability importance A method of ranking the basic events in the fault tree
measures to show their relative culpability in causing the top
event to occur. Importance measures are used to
detect critical design weaknesses and component
failures. They can assist you in identifying the fault
tree event that, if improved, is most likely to produce
the greatest improvement in system performance.
They can also help you determine if allocating
additional resources or adding redundancy to the
system would improve the overall system reliability.

Unavailability The probability that, at a given time, the system does
not function, due to either a failure or a repair.

Unreliability The probability that, during a given time period, the
top event occurs, and the system is unable to
function.

Frequency The frequency of failures over a time period.

Number of failures The number of failures in a period of time.
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Running FTA Calculations
To compute fault tree results:

1. Inthe FTATable, select BAT-FIRE.

2. Select System » Calculate, or click the calculate button ] on the standard

toolbar. The Calculate window opens.

3. In the left pane, select the Calculation Selection page if it is not already
selected.

4. In the right pane, click Clear All and then select FTA to run calculations only
for the FTA module.

5. In the left pane, expand the FTA folder if necessary and select the General
page.

Both this page and the Advanced page contain a number of calculation
options. The options shown depend on the FTA calculation type selected for
the System file. This file is for a time dependent tree.

6. Under Reliability/availability evaluation:

For Through end time, enter 30000.

a

b. For Number of data points, enter 11.
c. For Primary time point, enter 30000.
d. Select Perform exact calculations.

7. Under Calculations:

a. Leave Cut sets selected.

Select the following calculations as well:

» Reliability importance measures
* Unavailability
* Unreliability
* Frequency
*  Number of failures
* Failure rate
c. Select Calculate all gates.

Your page should now match the one in the following figure.
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A FTA Calculation Options

[T qualitative analysis only

Relil:}l]ilityfavailahility evaluation

From start time: 0 [] Perform exact calculations
Through end time: 30000 Start calculating at:

@ Toprost gate
Mumber of data points: 11

-, Current gate

Primary time paint: 30000 = (top of current page)
Calculations
[¥] cut sets () Calculate top gate only
[¥] Reliability importance measures @ Calculate all gates
[¥] Unavailability
[¥] Unreliability
[¥] Frequency

[¥] Mumber of failures

[¥] Failure rate

[ Meets safety criteria

[ Perform uncertainty analysis

Ignore cut sets with probabilities less than: 1] -

Ignore cut sets with an order greater than:  # -

8. In the left pane, select the Advanced page.

9. For Calculation method, select Exact.
For more information about all options for all tree types, click Help to open the
help.

10. Click OK to run the calculations. When the calculations are complete, the View
Calculation Results window opens.

= Tlp
You can print your calculation results by clicking Print in the View
Calculation Results window. You can also save them to a Microsoft Excel
spreadsheet by clicking Excel.

11. Click Close when you have finished reviewing results.

To display the results again at any time, you would select System > View
Calculation Results. If you have only one module enabled, the results shown are
only for this module. If multiple modules are enabled, a navigation pane is shown
so that you can select the pages for the results you want to view.
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Viewing Cut Sets

A cut set is a set of events that together cause the top event to occur. A minimal
cut set (MCS) is the smallest set of events, which, if they all occur, cause the top
event to occur.

During calculations, cut sets are calculated if you selected this option in the FTA
calculation properties. You can view cut sets, cycling through them one at a time.

To view cut sets:

1.
2.
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In the FTA Diagram pane, select the top BAT-FIRE OR gate.

Select FTA » Highlight Cut Sets.
The Task List window opens. In the Cut Set Highlighting area, the first cut set

is selected by default. In the FTA Diagram pane, the gates and events that make
up this cut set are highlighted in blue.

Task List * o x
Cut Set Highlighting -
|BATFIRE -|
|1:Q =0.0392105 v
Previous cut set
Mext cut set

~ Note

If you have the Project Navigator pinned into view, you might want to
unpin it and slide it out of view while you are viewing cut sets.

In the Task List window, click Next cut set to view the next cut set for the BAT-
FIRE OR gate. You can continue clicking this command until it becomes
unavailable, indicating that you are viewing the last cut set. To go back, click
Previous cut set.

~ Note

If the Next cut set and Previous cut set commands are both unavailable,
there is only one cut set to view.

On the FTA menu, select Highlight Cut Sets again to turn off cut set
highlighting and close the Task List window.
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Viewing an FTA Report

To view an FTA report:

1. In the Project Navigator, under Reports > FTA Reports, sclect (Common) FTA
(Summary). Because the three reports in this Report Binder file require input

data, the Report Properties window opens.

2. For the top report, do the following:

a. Under the Record Selection heading, select Print selected gate.

b. If BAT-FIRE is not already selected, click E to select it.
c. Verify that the Apply this selection to all reports checkbox is selected.

For the other reports, you can use the default values.

3. Click OK to generate the report and open it in a preview window. This report
outputs data related to a fault tree (top gate) in the System file. It includes
calculation data, gate and event details, and the fault tree diagram.

You can use the toolbar in this window to print your report, move through its
pages, switch between a two-page and one-page view, zoom in and out, and
close this window.

4. When finished viewing the report, do one of the following to close the
window:

¢ Select Preview » Close.

¢ Click the close button on the toolbar.

Graphing FTA Data

1. In the Project Navigator, under Graphs > FTA Graphs, sclect (Common) FTA
Unavailability v Time. The Select the Gate to Graph window opens.

2. Select BAT-FIRE, which is the top gate, and click OK to generate the graph for
the entire FMEA.

This graph displays system unavailability for gates at the points in time
specified in the Calculate window for FTA calculations.

3. When finished viewing the graph, select File » Close.

Additional FTA Features

PTC Windchill Quality Solutions supports many more fault tree features and
functions. A brief listing of other topics of interest is shown below. For more
information, see the help or guide for PTC Windchill Quality Solutions.
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You can use Fault Tree CCF Groups files to store CCFs (common cause
failures) to copy them into any fault tree. A CCF is an event or mechanism
that can cause two or more failures (basic events) to occur simultaneously.

You can use repeated events, which are basic events that you insert in more
than one place in the fault tree. When a repeated event occurs, it occurs
simultaneously everywhere you have inserted it.

You can use Fault Tree Event Library files to store commonly used events so
that these events, and their failure and repair parameters, can easily be copied
into any fault tree.

You can run exact calculations. Or, you can run cut set approximations to
expedite the analysis of large trees.

You can customize the appearance of gates and events, including colors, fonts,
images, and sizing.

You can define very long descriptions for your gates and events and have the
size of the figures automatically increased to fit the text.

You can link fault tree events to other modules. If the linked data changes,
these changes are automatically reflected within the fault tree. You can link
FTA events to data in the following modules: FMEA, Markov, and Prediction.

You can use PTC Windchill FTA automatic paging to better manage large fault
trees.

In addition to standard time dependent fault trees, you can build and evaluate
lambda tau and SAE ARP4754A and ARP4761 fault trees. You can also
import CAFTA files into PTC Windchill FTA.

You can use PTC Windchill Event Tree when you have a PTC Windchill FTA
license. The Event Tree module provides full event tree analysis capabilities.
This means that you can analyze the consequences that result from a sequence
of events occurring in your system.
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PTC Windchill RBD

Block DIagrams OVEIVIEW .........ccieiuiiiiiiiiie et 80
Getting Started with PTC WIndchill RBD ...........iiiiiii e 81
Using PTC WINAChIll RBD ... e 82
Understanding RBD CalCulations. ....... ... 86
Viewing an RBD REPOI ... oo it 91
Graphing RBD Data..........oiiiniiiee et 92
Additional RBD FEAUIES.......couuuiiiiiiiiie et 92

This section of the PTC Windchill Quality Solutions Getting Started Guide
provides basic information about building and evaluating RBDs (reliability block
diagrams) using PTC Windchill RBD. In this section, you learn how to create a
block diagram, insert and link blocks, and assign calculation properties. You also
run calculations and view reports and graphs.

~ Note

Because Projects can be fully customized, your screens might not look like the
ones shown in this guide.
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Block Diagrams Overview

Block diagrams are used to model systems which incorporate varying
configurations outside of the basic series (in-line) configuration, and are
especially useful in analyzing configurations that include redundant components.

When system components are connected in series, it indicates that all components
must be operational for the system to be successful. Once a single component fails
in the chain, the entire system is non-operational. But if the system utilizes
backups for components, then one failure does not cause the entire system to fail.
Instead, a backup unit can take over to keep the system up and running. Therefore,
designing redundancy into a system can often lead to increased reliability and
availability.

Different types of redundancy, such as parallel operating and standby non-
operating, exist. When items are in a parallel operating configuration, all are not
necessarily needed to be operational for the system to operate. For example, in a
simple system, two batteries might be set up in redundant configuration so that if
one battery fails, the backup battery can take over.

In this simple scenario, only one of the two components needs to be operational
for system success. In block diagram terms, this is usually described as a 1::2
parallel operating configuration. In the case of a standby non-operating
configuration, a system component is in standby mode awaiting failure of the first
unit. In block diagram terms, this is referred to as a 1::2 standby configuration.

Models become even more complex when you consider factors such as the switch
delay encountered in standby situations when the backup unit must be switched
on. You might also need to account for the fact that a parallel operating unit has a
higher failure rate than a standby unit because it is always powered. You can
envision how analyzing the reliability and availability of these systems can
become difficult without the help of software analysis packages.

Redundancy in system design is essential in cases where repair is either
impossible, such as in a launched space probe, or extremely costly, such as in a
ship at sea. In other systems, redundancy can play a vital role in ensuring system
availability is kept to a maximum.

Block diagrams can be used to model series systems, parallel systems, and
combinations of series and parallel systems. Parallel systems can be operating or
in standby.

If you are unfamiliar with block diagrams and would like to study this topic in
more detail, the following are excellent resources:

* Reliability: A Practitioner's guide (Chapter 4)

* Practical Reliability Engineering by Patrick D.T. O'Connor, 4th edition, John
Wiley & Sons Ltd. (2002)

* Reliability Analysis and Prediction: A Methodology Oriented Treatment by K.
B. Misra, Elsevier Science Publishers B.V. (1992)
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Optimization and Simulation

While a standard block diagram process lets you compute reliability and
availability, optimization and simulation tools take this a step further by allowing
you to incorporate information about maintenance activities, spare parts, and
repair resources.

PTC Windchill RBD provides optimization and simulation tools so you can
effectively address multiple facets of component maintenance, including the
definition and allocation of repair teams, the stocking and shipping to and from
offsite spares pools, and more. You can define maintenance plans that specify the
time interval, cost, and the type of maintenance being performed. You can also
specify labor costs and designate if repair is partial or perfect.

If you are unfamiliar with optimization and simulation techniques and would like
to study this topic in more detail, the following is an excellent resource:

* Optimal Reliability Design, by Way Kuo, V. Rajendra Prasad, Frank. A.
Tillman, Ching Lai Hwang, Cambridge University Press (2001)

Getting Started with PTC Windchill RBD

If PTC Windchill Quality Solutions is started and the Tablet PC
System file is open

If you are already using PTC Windchill Quality Solutions and your Project with
the Tablet PC System file is open, you can enable the RBD module. For more
information, see Enabling PTC Windchill RBD on page 82.

If PTC Windchill Quality Solutions is not started

If PTC Windchill Quality Solutions is not started, then start it. For more
information, see Starting PTC Windchill Quality Solutions on page 10.

If your copy of the Tablet PC System file is not open

The Tablet PC System file in your My Tablet PC Project is used to demonstrate
module features in this guide. If this System file is not open, then open it by doing
one of the following:

+ If'the Recent Files control on the Start Page lists the Tablet PC System file in
the My Tablet PC Project, click this file name to open the file.

» If the Project Navigator shows a listing of your Projects and Systems (you see
a Click a file to open link), click Tablet PC under My Tablet PC to open the
System file.
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» If'the Project Navigator shows that a different Project is open (you see a name
other than My Tablet PC after the Project: label):

1. Close all open files by clicking < Click to close Project >.
2. Under My Tablet PC, click Tablet PC to open the System file.
» If the Project Navigator has the My Tablet PC Project open (you see Project: My

Tablet PC in the Project Navigator), click Tablet PC under the Systems heading
to open this System file.

Enabling PTC Windchill RBD

|| ]
On the Module Selections toolbar, select the RBD button ™ = and disable all other
module buttons.

The System file displays only PTC Windchill RBD panes.

Using PTC Windchill RBD

The top window contains three tabbed panes:

* Problems — Displays a list of problems and is shared with several other
modules.

* RBD Table — Displays all diagrams in the System file. These diagrams are
organized into two folders: Block Diagrams and Phase Diagrams. This System
file currently contains three block diagrams. The first two model the entire
tablet PC in different phases of use, while the third models the hard drive
assembly, which includes two hard drives. These hard drives are placed in
parallel to increase availability through the use of redundancy. In addition, this
System file includes a phase diagram, which is designed to evaluate the
components of the tablet PC during various phases of the mission.

* RBD Blocks — Displays a table view of the selected diagram.
The bottom window contains two tabbed panes:

* Problems Form — Displays a sample form for entering data about the active
problem in the Problems table.

* RBD — Displays a graphical view of the selected diagram. For ease of
viewing, you can resize this pane using the splitter control, which appears
when you place the mouse cursor between the two panes.

For this example, you add an additional block diagram to model the memory
board assembly of the tablet PC. First, you create a simple block diagram and
insert blocks into it. Then you connect the blocks, assign calculation properties,
and link one of the blocks to an assembly in the system tree.
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Creating a Simple Block Diagram

1.
2.

In the RBD Diagrams table, sclect the Block Diagrams folder.

Select Insert » New Block Diagram. A new block diagram is inserted and, in
the RBD Diagram pane below, only start and end nodes are present.

All block diagrams start at the start node and then provide one or more paths
through the blocks to the end node. When a functioning path exists from the
start node through the end node, the system is operating.

. To insert data about the diagram in the RBD Table, do the following:

a. For Identifier, enter Memory Board; then, press the Tab key

b. For Description, enter Block Diagram for the Memory Board

Assembly. Do not press the Tab key as this would cause the Phase
Diagrams folder to be selected.

Inserting Blocks into a Block Diagram

1.
2.

In the RBD Table, ensure the Memory Board block diagram is selected.

In the RBD Diagram pane below, right-click and select Insert Default Block.
The cursor changes in appearance to show that you are inserting blocks.

Click near the start node to insert a block.

4. Move to the right and click again to insert another block.

Right-click to exit insertion mode.

Connecting Blocks in a Block Diagram

1.

Place the mouse cursor over the triangle connection point on the right side of
the start node, until the cursor changes shape to a long arrow.

Click the triangle connection point on the right side of the start node and then
click the first block. The start node is now connected to the first block.

Click the triangle connection point on the right side of the first block and then
click the second block. The first block is now connected to the second block.

o Tip
You can also select RBD » Auto Connect Blocks to automatically connect
blocks based on the order in which they were inserted.
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Assigning Block Calculation Properties

The memory board assembly consists of the memory board controller and two
memory boards. For the purposes of this example, assume that the memory boards
are operating in a redundant configuration so that you can learn how to model
redundancy in PTC Windchill RBD.

1.

2.
3.
4
5

>

Double-click the left block to open the Calculation Properties window.
On the General page, for Assembly, enter MEM061789.

For Part Number, enter DRAM512-31.

In the left pane, select the Failure page.

For Failure Distribution, click the browse button L] to open the Distribution
window.

Leave Distribution set to Exponential.

Leave Failure rate selected. Then, to the right, enter 0.39651 6 for the failure
rate.

Click OK to close the Distribution window. The Calculation Properties window
now displays the specified exponential failure rate for Failure Distribution.

For the remaining parameters, use the default values.

Failure

Failure Distribution: Exponential: FR. = 0.396516

Duty Cyde Percentage: 100

Standby failure properties

Standby Aging Percentage: 0,00

Standby Failure Detection: ISeIf announcing "’I
Standby Failure Type: [P'err_enmge aof online failure rate "I
Standby FR Percentage: 0.00

Exponential: FR. =0

10. In the left pane, select the Redundancy page.

11. For Quantity, enter 2.

12. For Redundancy Type, sclect Parallel Operating.
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13. Leave Quantity Required sct to 1 and Switch Probability of Success set to
1.000000.

14. Click OK. In the block diagram, the first block shows the redundancy. You
might need to drag the right-most block further to the right to adjust the space
between the blocks.

Linking Blocks to Other Modules

If the block diagram you are creating includes assemblies from your system tree,
you can efficiently access this data using links. When you link blocks in a block
diagram to items in other modules, PTC Windchill RBD pulls in information from
these other modules.

Not only does linking the data reduce data entry, but it also has the additional
advantage of keeping the linked data updated. When you make changes to your
assemblies and recalculate failure rates, these new values are automatically used
in your block diagram.

To create a block that is linked to an assembly in the system tree:

1. In the RBD Diagram pane, right-click the right-most block and select Data
Linking > Link Data. The Link Data window opens.

2. For Data source, select Prediction to link to an assembly in this module.
This System file has only one configuration. If it had multiple configurations,

Configuration would be the next field shown. In it, you would select the
configuration with the assembly to which you want to link.

Click the arrow next to the System Tree Item list to open a selection window.
4. Expand the memory assembly MEM061789 and select the DRAMC7001
assembly.
5. Click OK to close the Link Data window.

In the block diagram, the block shows data for the linked DRAMC7001 assembly.

A link icon E4 appears near the upper right corner of the block to visually indicate
that the block is linked to data in another module.

If you enabled both PTC Windchill RBD and PTC Windchill Prediction, you
would be able to drag assemblies from the System Tree Items table in the upper

window and drop them into the RBD Diagram pane in the lower window to create
linked blocks.
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Understanding RBD Calculations

PTC Windchill RBD computes a variety of reliability and availability metrics. A
sampling of supported calculations is outlined below and brief descriptions are
provided. For more information, see the guide or help for PTC Windchill Quality

Solutions.

Calculation

Description

MTBF

The mean number of hours between two consecutive system
failures in a long run. MTBF (mean time between failures)
includes both operational and downtime hours between two
consecutive failures, and it is the average distance in hours
between two failures in a long run. On the Advanced page in
the RBD calculation properties, you specify the run length for
Number of system failures to reach steady state.

MTTF

The expected or average time to failure in hours. For
repairable systems, MTTF (mean time to failure) is the
average time to reach the first system failure. Hence, it is also
called MTTFF (mean time to first failure). If you select
Account for repair in reliability on the General page in the
RBD calculation properties, reliability is calculated using the
failure and repair information supplied in the calculation
properties for blocks, and this reliability value is then used to
calculate MTTF.

MTTR

MTTR (mean time to repair) is the average time it takes to
repair a failed system and return it to an operational state,
based on the repair time distributions for its repairable
components or blocks. MTTR can be calculated by
considering the frequency of each failure scenario and its
respective average repair times.

Optimal number
of spares

The number of spares that minimizes or maximizes a
specified objective function or the goal. If the goal is
minimizing the total cost, then the optimal number of spares
represents the number of spares corresponding to the
minimum total cost. Similarly, if the goal is maximizing the
mean availability, then the optimal number of spares is the
number of spares that maximizes the mean availability. The
optimal number of spares is calculated by evaluating the
function specified in the goal with varying number of spares.
For example, if the goal is minimizing the total cost, then the
total cost is calculated for different numbers of spares. The
optimal number of spares corresponds to the minimum value
of the total cost.

Optimal
maintenance
intervals

The value of the periodic maintenance interval that minimizes
or maximizes a specified objective function or the goal. If the
goal is minimizing the total cost, then it is the value of the
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Calculation

Description

maintenance interval corresponding to the minimum total
cost. Optimal maintenance intervals are calculated using
optimization algorithms integrated within the simulation
engine.

Optimal repair
resources

The number of the repair resources that minimizes or
maximizes a specified objective function or the goal. If the
goal is minimizing the total cost, then it is the number of
repair resources corresponding to the minimum total cost.
The optimal repair resources are calculated using
optimization algorithms integrated within the simulation
engine.

Reliability

The probability that a system remains operational until a
specified time. Reliability is a time-based probability value,
so it is always a metric between 0 and 1. A reliability of 0
means that the system always fails before the specified time
or never functions until the specified time. A reliability value
of 1 indicates that the system is always successful or never
fails during the specified time. The system reliability value is
calculated using both the system configuration specified in
the block diagram and the failure distribution specified in the
calculation properties of the blocks. If all blocks are in series,
and all of them follow exponential failure distributions, then
the system itself follows an exponential failure distribution,
and the failure rate is the sum of the failure rates of its
components. If you select Account for repair in reliability on
the General page in the RBD calculation properties,
reliability is calculated using the failure and repair
information supplied in the calculation properties for blocks,
and this reliability value is then used to calculate MTTF.

Unreliability

The probability that a failure occurs during a given time
period.

Failure Rate

The chance of failure at a specified time given that the system
is not yet failed. It also represents the expected number of
system failures per unit time given that no failure has
occurred in the system until the specified time. It is a time-
based metric and also known as instantaneous failure rate.
The failure rate function can be used to study the behavior of
the system's failure over time. Furthermore, the failure rate
function, (), is an important representation in the lifetime
modeling of the system due to its intuitive interpretation as
the amount of risk of failure associated with the system at
time t. If you select Account for repair in reliability on the
General page in the RBD calculation properties, reliability is
calculated using the failure and repair information supplied in
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Calculation

Description

the calculation properties for blocks, and this reliability value
is then used to calculate failure rate.

Availability

The probability that the system is operating properly at a
specified time. Availability, like reliability, is a time-based
probability metric, so it is always a metric between 0 and 1.
Hence, it is also called point availability or instantaneous
availability. When availability is calculated without
considering logistic delays, then it is called inherent
availability. When logistic delays are considered in the
availability calculation, then it is called operational
availability. PTC Windchill RBD can calculate either
availability or operational availability in a single calculation.
Availability is a function of both reliability (how quickly the
system fails) and maintainability (how quickly the system is
repaired). A common term, "five nines", refers to a system
which has an availability of 0.99999, which means that it is
operational 99.999% of the time.

Mean availability

The average availability over a specified time interval. Mean
availability is the ratio of the mean total uptime to the total
time over a specified interval.

Steady state
availability

The availability in a long run, or as time tends to infinity.
Steady state availability is the ratio of the total uptime to total
time in a long run. On the Advanced page in the RBD
calculation properties, you specify the run length for Number
of system failures to reach steady state.

Unavailability

The probability that, at a given time, the system does not
function, due to either a failure or a repair.

Total downtime

The total downtime of the system during the specified time
interval.

Running RBD Calculations

To calculate RBD results:

1. In the RBD Table, select Tablet PC.

2. Select System » Calculate, or click the calculate button &

on the standard

toolbar. The Calculate window opens.

3. In the left pane, select the Calculation Selection page if it is not already

selected.

4. In the right pane, click Clear All and then select RBD to run calculations only
for the RBD module.
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5. In the left pane, expand the RBD folder if necessary and select the General
page.

Both this page and the Advanced page contain a number of calculation
options.

6. On the General page, leave all default values.

i RBD Calculation Options

Evaluation

From start time:
Through end time:
Mumber of data points:

Display results for blocks at time:

Required capadity:

Reliability calculations

Reliability

MTTE

Failure rate

[ Equivalent failure rate

Availability calculations

Availability

MTBF

[] Effective MTBF

[CIMTTR

[ Hazard rate

[] Mean availability

Cut set calculations

[ calculate cut sets

Other calculations
|:| Cost

30000
11
30000

100

[¥] Account for repair in reliability

[T steady state availability
Total downtime

Expected number of failures
[ Failure frequency

[ operational avaiability

|:| Capadty

[ caleulate path (tie) sets

Reliability equation

7. In the left pane, select the Advanced page.

8. On this page, also leave all default values.
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l.!i RBD Advanced Calculation Options

Simulation

[T Force Monte Carla simulation

Mumber of simulation iterations: 1000
Mumber of system failures to reach steady state: 1
Begin repairs {default): ’Immediately ']
Metwork type: IFJectricaI Metwork o I
[¥] specify random number seed: 1

[¥] Companents continue to operate when system is failed
[¥] Treat switch delays as failures

[T Record simulation log for first iteration of availability measures

Confidence intervals

[ Reliability 95 | 5

=

[ Availability 95 | o

o
=l

[ mTBF o

=}
;

[ mTTE Yo
Linked diagrams

[¥] save linked diagram results

9. Click OK to run the calculations. When completed, the View Calculation

Results opens.

10. In the left pane, expand the RBD Results folder if necessary and select the

11. Click Close when you have finished reviewing results.

General page.

¢ Tip

You can print your calculation results by clicking Print in the View
Calculation Results window. You can also save them to a Microsoft Excel

spreadsheet by clicking Excel.

To display the results again at any time, you would select System » View
Calculation Results. If you have only one module enabled, the results shown are
only for this module. If multiple modules are enabled, a navigation pane is shown

so that you can select the pages for the results you want to view.
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Viewing the Reliability Equation

When PTC Windchill RBD analytically computes diagram results, you can view
the equation that was used to calculate reliability. However, to do this, Reliability
equation must have been selected under Other calculations on the General page
for RBD calculation properties prior to calculating.

To view the reliability equation:
1. In the RBD Table, select Tablet PC.

2. Select System » View Calculation Results. The View Calculation Results
window opens.

3. Ifnecessary, expand the RBD Results folder.
4. In the left pane, select the Equation page to view the reliability equation used
to calculate the results for the Tablet PC diagram.

R

Tablet PC . RMotherboard ~ TTonchpanel - FMemory
Board RHard Disk Assembly . RBatter_&:

5. Click Close to close the View Calculation Results window.

Viewing an RBD Report
To view an RBD report:

1. In the Project Navigator, under Reports > RBD Reports, sclect (Common) RBD
(Summary) Portrait. Because the three reports in this Report Binder file require

input data, the Report Properties window opens.

2. For the top report, do the following:
a. Under the Record selection heading, select Print selected diagram.
b. If Tablet PC is not already selected, click IZI to select it.
c. Verify that the Apply this selection to all reports checkbox is selected.

For the other reports, you can use the default values.

3. Click OK to generate the report and open it in a preview window.

You can use the toolbar in this window to print your report, move through its
pages, switch between a two-page and one-page view, zoom in and out, and
close this window.

4. When finished viewing the report, do one of the following to close the
window:
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¢ Select Preview » Close.

¢ Click the close button on the toolbar.

Graphing RBD Data

1. In the Project Navigator, under Graphs > RBD Graphs, sclect (Common) RBD
Reliability v Time to generate this graph. The Select RBD Diagrams window

opens.
Leave Tablet PC selected and click OK to generate the graph.
When finished viewing the graph, select File » Close.

Additional RBD Features

PTC Windchill RBD supports many more block diagram features and functions. A
brief listing of other topics of interest is shown below. For more information, see
the help or guide for PTC Windchill Quality Solutions.

*  You can model a wide array of system complexities including limited repair
resources, fixed and variable costs, switching mechanisms, imperfect repairs,
switch delays, transportation delays, and logistic delays.

* You can use advanced simulation and optimization features to evaluate
optimal maintenance intervals, repair resources, and spares.

* You can model hot, cold, and warm spares.

* You can use junctions to model redundant configurations of non-identical
components.

* You can compute confidence intervals for various reliability metrics.

* You can use diagram links to link one block diagram to another, thereby
creating a parent/child relationship.

* You can select from a large number of distributions, including exponential,
lognormal, normal, Rayleigh, time independent, Weibull, uniform, and
constant time.

* You can model both electrical and flow type networks.

*  You can create phase diagrams, which take into account operation on all of the
various phases that the system experiences during a mission.

* You can specify not only calculation properties but also visual properties for a
block or connector. If you want, you can even show a custom image for a
block.
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PTC Windchill FRACAS
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Additional FRACAS FEAUMES ........oii ittt e eeeees 101

This section of the PTC Windchill Quality Solutions Getting Started Guide
provides information about a FRACAS (failure reporting, analysis, and corrective
action system) and how to use it to track, measure, and ultimately improve the
reliability of a product, service, process, or software application.

In this section, you learn how to enter incidents in PTC Windchill FRACAS, how
to filter your data, and how to view outputs such as reports and graphs.

~ Note

Because Projects can be fully customized, your screens might not look like the
ones shown in this guide.
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Overview of FRACAS

A FRACAS is a closed-loop incident reporting and corrective action system. This
type of system is also known as a DRACAS (data reporting, analysis, and
corrective action system), PRACA (problem reporting, analysis, and corrective
action), and various other names. Reducing the cost of poor quality (COPQ),
improving the next generation of product design, reducing warranty costs, and
ensuring compliance are some of the key reasons organizations deploy closed-
loop corrective action systems.

A FRACAS can be the means by which the reliability of a product, service,
process, or software application is tracked, measured, and ultimately improved. A
FRACAS must provide for accurately recording and analyzing significant incident
information so that effective corrective actions can be quickly identified,
implemented, and verified.

PTC Windchill FRACAS allows you to create a completely customized FRACAS
for data entry, analysis, and reporting.

If you are unfamiliar with FRACAS and would like to study this topic in more
detail, the following are some recommended resources:

* Failure Reporting, Analysis, and Corrective Action System (FRACAS)
Application and guidelines, a 1999 publication of the Reliability Analysis
Center (RAC)

*  MIL-STD-2155(AS): Failure Reporting, Analysis and Corrective Action
System

Getting Started with PTC Windchill
FRACAS

If PTC Windchill Quality Solutions is started and the Tablet PC
System file is open

If you are already using PTC Windchill Quality Solutions and your Project with
the Tablet PC System file is open, you can get started by activating the FRACAS
module. For more information, see Activating PTC Windchill FRACAS on page
95.

If PTC Windchill Quality Solutions is not started

If PTC Windchill Quality Solutions is not started, then start it. For more
information, see Starting PTC Windchill Quality Solutions on page 10.
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If your copy of the Tablet PC System file is not open

The Tablet PC System file in your My Tablet PC Project is used to demonstrate
module features in this guide. If this System file is not open, then open it by doing
one of the following:

» If the Recent Files control on the Start Page lists the Tablet PC System file in
the My Tablet PC Project, click this file name to open the file.

+ If the Project Navigator shows a listing of your Projects and Systems (you see
a Click a file to open link), click Tablet PC under My Tablet PC to open the
System file.

» If the Project Navigator shows that a different Project is open (you see a name
other than My Tablet PC after the Project: label):

1. Close all open files by clicking < Click to close Project >.
2. Under My Tablet PC, click Tablet PC to open the System file.

» If the Project Navigator has the My Tablet PC Project open (you see Project: My
Tablet PC in the Project Navigator), click Tablet PC under the Systems heading
to open this System file.

Activating PTC Windchill FRACAS

On the Module Selections toolbar, select the FRACAS button ' and deselect all
other module buttons.

The System file displays only PTC Windchill FRACAS panes.

Using PTC Windchill FRACAS

The top window contains two tabbed panes:

* System Tree Items — Displays the hierarchical breakdown of your system and
is shared with several other modules.

* Problems — Displays a list of problems and is shared with several other
modules.

The bottom window also contains two tabbed panes:

* Problems Form — Displays a sample form for entering data about the active
problem in the Problems table.

* FRACAS Incidents — Displays the incidents entered for the active System
Tree Items record.

* FRACAS Incident Form — Displays a sample form for entering incident data
for the active System Tree Items record.
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A FRACAS in PTC Windchill FRACAS can be extensively customized. You can
select which data fields appear and give them custom names. As a result, the
FRACAS that you use might not look exactly like the one in this guide.

Additionally, in the Enterprise EditionPTC Windchill Quality Solutions supports
performing FRACAS activities on the Web using PTC Windchill Quality
Solutions Web Access.

Entering Incidents

The main data element of your FRACAS is an incident or a failure report of some
type. For this example, you enter an incident in the Tablet PC System file in your
My Tablet PC Project. In any Project, you can customize the tables and forms in
which you enter incident data.

1. In the System Tree Items table, select Touchpanel to display the incidents
associated with this assembly in the FRACAS Incidents table.

2. In the last row in the FRACAS Incidents table, click < Click here to insert a new
record >. A new incident is added. Both Incident ID and System Tree ltem are

filled in automatically.

Note that the newly entered incident appears in red. By default, all open
incidents appear in red to highlight them. This is a setting that you can
customize.

For Location, select Austin.
For Technician, select Arnold Palmer.
For Serial Number, enter 42661.

AN N

=]
For Occurrence Date, click in the field to make the calendar icon ** available.
Then, click this icon to display the calendar control.

~

Select today's date.

For Incident Description, enter Customer reports that the
touchpanel is non-responsive in a certain area.

9. Leave the Closed? checkbox cleared. You select this checkbox only after the
incident has been analyzed and corrective action implemented.

10. View the other data ficlds in the FRACAS Incidents table. Most of these fields
are related to subsequent steps in the FRACAS process, such as corrective
action, analysis, and close out. For this example, do not enter any further data.

It is often easier to enter and modify your FRACAS data on a form. A form allows
you to view the data for one record at a time in a larger format for easier entry. In
your FRACAS implementations, you can decide whether to use a table and/or a
form. When both views are available, you can use which ever you find most
comfortable.
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To view and enter incident data on a form:
1. Select FRACAS Incident Form.
In the Incident Analysis area, for Date, enter today’s date.

For Analysis By, sclect Ethan.

v

For Analysis Description, enter Found hairline crack in upper
right portion of the touchpanel. Contacted customer who
reported that original shipping container had arrived
slightly damaged.

For Failure Mode, select Cracked, Fractured.
Select the FRACAS Incidents table to return to this table.

Filtering FRACAS Data

Due to the large number of incidents that can be accumulated over time, PTC
Windchill FRACAS supports data filtering to allow you to view a subset of
incidents based on criteria you specify. For example, you can view only the
incidents for which you are responsible, all the incidents that are currently open,
or a combination of the two.

PTC Windchill FRACAS supports both fixed-value filters and parameterized
filters for all of its tables. When you create a parameterized filter, you must supply
a parameter value when the filter is applied. You can also build filters with
multiple parameters. When building a parameterized filter, be aware that the
request for a parameter value occurs whenever the filter is used, even during
report or graph generation.

Using Predefined FRACAS Filters

A number of predefined filters are supplied with the FRACAS module. For
example, you can apply a filter to limit FRACAS Incidents records to only open
incidents.

1. Select the FRACAS Incidents table.

2. In the filter selection box in the standard toolbar, select Open Incidents. Only
incidents that are not marked as closed are shown in the table.

3. In the filter selection box, select — No Filter — to remove this filter.

Creating Custom FRACAS Filters

You can use the Filter Wizard to create any number of custom filters.

To create a custom FRACAS filter:
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10.
I1.
12.

13.
14.

98

Select Filter » Filter Wizard or click the Filter Wizard button in the

standard toolbar. The Filter Wizard starts and displays the Specify Filter
Features page.

Leave Selects records only selected and click Next. The Specify Filter Field
page appears.
For Select the table type, select FRACAS Incidents.

From the list of fields, select Technician; then, click Next. The Specify
Condition page appears.

Leave is equal to selected and click Next. The Specify Field Value page
appears.

Leave Use a fixed value (specify the value below) sclected.

For Specify the value for ‘Technician’ here, click the browse button. A selection
window opens.

Select the checkbox for Hugh Downs and click OK, which closes the selection
window.

Click Next. The Review Filter page appears.

Ensure that | want to add more conditions to the filter is cleared to indicate that
the filter is complete; then, click Next. The Save Filter page appears.

Select | want to save my filter for later use.
For Filter name, enter Technician Hugh Downs.
Select Save filter to My Filter File.

You have the option of saving filters to two different locations.

+ Ifyou select Save filter to My Filter File, your new filter is stored in a file
accessible only to you. The filter is not accessible to other users with filter
permissions.

» If you select Save filter to the Filter File in this Project, the filter is
accessible to other users with filter permissions.

In some cases, you might be creating a filter that is for your own use. In that
case, it is best to save it to your My Filter file. In other cases, if you are
creating a filter you know would be helpful to all team members, you would
want to save it to the Project Filter file so others can use it.

Click Next. The Wizard Complete appears.
Click Finish.

If this is the first time you have saved a personal filter, PTC Windchill Quality
Solutions asks if you want to create a My Filter file in which to store your
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newly constructed filter. In the Create Support File window, click Yes to create
this file.

If you have previously created a My Filter file, this message does not appear.
If a message appears asking if you want to overwrite or use the existing file,
select Use Existing.

The filter is applied to your data so that only incidents assigned to technician
Hugh Downs are shown. Your new filter is shown in the filter selection box. In
the list for this selection box, your new filter, Technician Hugh Downs, is
preceded with a person icon instead of a PTC Windchill Quality Solutions
icon. This indicates that the filter is stored in your My Filter file and not in the
Project Filter file. All Project filters are preceded with a folder icon.

15. To return to the original data view, select — No Filter — in this selection box.

You can view and modify your personal filters by clicking My Filter File in the

Project Navigator to open your My Filter file. You can insert new filters directly in
this file.

Additionally, you can quickly build filters using the filter bar, which is located
above the column headers of the tables that support it. Using the filter bar, you can
sort and/or select the records to show in the table. You can also save filters created
using the filter bar by clicking the save icon ™ in the left corner of the filter bar.

F 5 Incidents
Fil =l

¥ | Incident ID | System

You can create the same custom filter from the previous exercise using the filter
bar.

To use the filter bar:
1. Select the FRACAS Incidents table.

2. In the filter bar, for Technician, click the icon for selecting a filtering
condition.

=0

Technician

Select is equal to for the condition.
Click in the area to the right of the condition A selection window opens.
Select the checkbox for Hugh Downs.
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6. Click OK. The selection window closes and the FRACAS Incidents table is
updated to show only incidents assigned to technician Hugh Downs.

7. To return to the original data view, in the filter bar, click the icon for selecting
a filtering condition for Technician and select (not filtered).

Viewing a FRACAS Report
To view a supplied FRACAS report:

1. In the Project Navigator, under Reports > FRACAS Reports, select (Common)
FRACAS Incidents by Part Number to generate this report and open it in a

preview window.

This report outputs data on all incidents by part number. For each part number,
this report includes incident identifiers, descriptions, and incident occurrence
and entry dates. It also indicates who entered the incidents and analyzed the
incidents, supplies descriptions of the corrective actions taken, and notes
which incidents are closed.

You can use the toolbar in this window to print your report, move through its
pages, switch between a two-page and one-page view, zoom in and out, and
close this window.

2. When finished viewing the report, do one of the following to close the
window:

* Select Preview » Close.

¢ Click the close button on the toolbar.

Graphing FRACAS Data

The FRACAS module has several supplied graphs and supports the creation of
custom graphs. During the installation of PTC Windchill Quality Solutions, Graph
Template files for all supplied graphs are copied into the Common Library so that
they are available for immediate use with all your Projects. You can generate a
graph using any Graph Template file in the Project or in the Common Library. All
Graph Template files in the Common Library have (Common) as a prefix.

To generate a supplied FRACAS graph:

1. In the Project Navigator, under Graphs > FRACAS Graphs, select (Common)
FRACAS Incidents per Part Number to generate this graph.

This graph displays the number of incidents for each part number as a cylinder
bar graph.

2. When you are finished viewing the graph, select File » Close.

100 Getting Started Guide



Additional FRACAS Features

PTC Windchill FRACAS includes a number of features and functions. A brief
listing of other topics of interest is shown below. For more information, see the
help or guide for PTC Windchill Quality Solutions.

*  You can use PTC Windchill Quality Solutions Web Access to perform
FRACAS tasks via the Web. This zero-client, web-based application provides
a rich Windows-like user interface. The web version provides significant
advantages for enabling FRACAS tasks to be performed in a collaborative
environment through its global accessibility.

* You can run MTBF calculations using your actual incident data. If you track
the operational time of your system, the FRACAS module can run a wide
variety of MTBF calculations, which you can customize even further by
applying filters.

* You can use the “on-the-fly” Format Builder to modify FRACAS tables with a
simple right-click.

*  You can import FRACAS data using the Import Wizard. This feature enables
you to directly populate your FRACAS data with incident data collected from
other sources.

* In the Enterprise Edition, you can also:

O Use a customized workflow process so that when an incident moves from
one process state to another an email message is automatically sent to the
appropriate personnel, notifying them of the update.

O Use the Alerts application to send customized notifications to system users
based on criteria you define.

Use the Audit Trail application to track data modifications for audit
requirements.

O Create Projects from PTC Windchill PDMLink/MPMLink products, where
you can visually distinguish hardware and software elements in the system
tree.

O Associate a FRACAS incident with an existing PTC WindchillCAPA or
change management object or manually create and delete associations.
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This section of the PTC Windchill Quality Solutions Getting Started Guide
provides basic information about Weibull analysis and how to evaluate failure data
using PTC Windchill Weibull.

In this section, you create a new data set in the Weibull module and find the
distribution that best fits the data points. You then view and customize the
resulting plot and generate a report.

~ Note

Because Projects can be fully customized, your screens might not look like the
ones shown in this guide.
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Weibull Analysis Overview

The Weibull distribution is widely used in reliability engineering. While the
Weibull distribution is important for life data analyses, Weibull packages typically
encompass support for various other significant distributions used in statistical
analyses, such as exponential, normal, and lognormal.

Weibull analysis, also called life data analysis and failure data analysis, is used a
wide variety of applications. For example, you can use Weibull analysis to
evaluate field failures or test failures. The idea is to determine a best fit
distribution for the collected sample data so that you can uncover or predict
trends.

To perform a Weibull analysis, the first and most important step is to gather sound
life data. You must identify the failure usage scale, which are the units for the age
of the component or system being tested. Age might be measured in units of
operating hours, miles, or cycles. It is also important to analyze one failure mode
at a time.

Once you identify the data associated with failure, you can enter the data, select
the distribution and estimation method, calculate and graph results, and predict
future trends.

If you are unfamiliar with and would like to study this topic in more detail, the
following selections are excellent references:

* Reliability: A Practitioner's guide (Chapter 7)
* The New Weibull Handbook, 5th ed., by Dr. Robert B. Abernethy

Further details are available at http://www.bobabernethy.com/products
handbook.htm.

Getting Started with PTC Windchill
Weibull

If PTC Windchill Quality Solutions is started and the Tablet PC
System file is open

If you are already using PTC Windchill Quality Solutions and your Project with
the Tablet PC System file is open, you can enable the Weibull module. For more
information, see Enabling PTC Windchill Weibull on page 105.

If PTC Windchill Quality Solutions is not started

If PTC Windchill Quality Solutions is not started, then start it. For more
information, see Starting PTC Windchill Quality Solutions on page 10.
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If your copy of the Tablet PC System file is not open

The Tablet PC System file in your My Tablet PC Project is used to demonstrate
module features in this guide. If this System file is not open, then open it by doing
one of the following:

» Ifthe Recent Files control on the Start Page lists the Tablet PC System file in
the My Tablet PC Project, click this file name to open the file.

+ If the Project Navigator shows a listing of your Projects and Systems (you see
a Click a file to open link), click Tablet PC under My Tablet PC to open the
System file.

» If the Project Navigator shows that a different Project is open (you see a name
other than My Tablet PC after the Project: label):
1. Close all open files by clicking < Click to close Project >.
2. Under My Tablet PC, click Tablet PC to open the System file.

» If the Project Navigator has the My Tablet PC Project open (you see Project: My
Tablet PC in the Project Navigator), click Tablet PC under the Systems heading
to open this System file.

Enabling PTC Windchill Weibull

On the Module Selections toolbar, select the Weibull button lé and deselect all
other module buttons.

The System file displays only PTC Windchill Weibull panes. For both this module
and the ALT module, a three-window interface is used. The upper left window
displays the LDA Navigator, which you use to select an analysis type and manage
data sets.

LDA Navigator

The LDA Navigator displays your list of data sets. When you select a data set in the
LDA Navigator, the other two windows in the System file display information
specific to this data set.

Data sets are organized by analysis types. Under Analysis type, you click the type
of data sets you want to view.

For the Weibull module, three analysis types are available:

* Life Data — Consists of parametric life data sets, non-parametric life data sets,
and reliability growth data sets. You can also insert data sets for plotting
multiple data sets concurrently on a plot.

* Warranty Analysis — Consists of warranty data sets, which contain data about
when a failed product was produced or sold and the date it was returned from
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the field. You can also extrapolate a life data set from warranty data and
analyze it using typical life data analysis techniques.

» Degradation Analysis — Consists of degradation analysis sets, which use the
changing rate of degradation of a product and a critical value at which the unit
1s assumed to fail to create a model for predicting the times at which the
product will fail in the future. You can also extrapolate a life data set from
degradation information and analyze it using typical life data analysis
techniques.

In the LDA Navigator, you can create new data sets and delete data sets you no
longer need. You can also further organize the data sets for any analysis type by
creating subfolders.

Weibull Parameters

The window beneath the LDA Navigator contains a number of tabbed panes,
depending on the selected analysis type.

*  When Life Data is selected, this window contains either two or three panes:
Parameters, Advanced (when applicable), and Plot Options.

*  When Warranty Analysis is selected, the previous three panes are available as
well two additional panes: Warranty and Forecast Parameters.

*  When Degradation Analysis is selected, only two panes are available:
Parameters and Plot Options.

The two panes common to all life data sets display analysis parameters and plot
options.

» Parameters — Specifies parameters for analyzing the selected data set.

* Plot Options — Specifies the number and type of plots to display in the
Weibull Plot pane in the window on the right.

When the Advanced pane is applicable, it specifies the estimation method and any
needed distribution parameters.

When a life data set is calculated, results display at the bottom of panes in which
you enter parameter, in the Calculation results area. Here, you can specify a fixed
value for a particular calculated value if you want. The results shown depend on
the distribution selected.

All panes in the lower right window display toolbar buttons on the right side of
the title bar. Buttons are available only when they are applicable to the active data
set.

You can click these toolbar buttons to perform common tasks, including:
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Calculating the active data set
Showing the plot for the active data set
Opening the Summary Calculator window to perform additional calculations

Running best fit distribution analysis

Weibull Data Points

When a life data set is selected in the LDA Navigator, the window to the right
contains three tabbed panes:

Problems Form — Displays a sample form for entering data about the active
problem in the Problems table.

Weibull Data Points — Displays the data you want to analyze. The column
headings in this table vary, depending on the type of life data set.

Weibull Plot — Displays a plot for the data set and the one or more
distributions applied to it. The parameters, distribution, and number of plots
shown depend on selections made on the panes in the lower left window.

Tip

You can modify the column heading in the Weibull Data Points table to suit
your process needs. Simply double-click the column heading and then specify
the desired name in the Change Column Name window that opens.

Using PTC Windchill Weibuli

You now create a data set, enter data points, and find the distribution that best fits
your data points. After viewing and modifying the plot, you generate a report.

Creating a Data Set

To create a new data set:

1.

In the LDA Navigator, under Analysis type, click Life Data to ensure you are
viewing life data sets.

In Data Sets, sclect the Life Data folder.

Select Insert » LDA Data Set. A new life data set named LDA Data Set is
inserted in the folder. It is already selected.

Enter My Weibull Data Set as the name of this data set.
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Select the Parameters pane in the lower left window.

6. Leave the default values.
Weibull Parameters
Data type: IExact Times
: Suspensions L-_] Grouped
Distribution: [Weibull = I
Model: IZ Parameters - I

Entering Data Points

Once the analysis parameters are specified, you enter data points in the Weibull
Data Points table. You can either specify the data points manually, or you can
copy and paste them from a word-processing file, spreadsheet, or other electronic

file.

For this example, you use the built-in random data point generator to create a set
of data points. In actual use, you would not create a data set in this manner. It is a
feature available for testing and sample data generation.

1. Select the Weibull Data Points pane.

2. Select LDA » Generate Random Data Points. The Generate Random Data

Points window opens.

Percent suspensions is unavailable because the Suspensions checkbox was

not selected in the Weibull Parameters pane.

3. Leave the default values.

Generate Random Data Points
Quantity: 10 0
B: 2
n: 10
[ QK ] [ Cancel ] [ Help

4. Click OK to generate the random data points.
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Finding the Best Fit Distribution

Once you have entered your data, you can determine the failure distribution that
best represents your life data. PTC Windchill Weibull and PTC Windchill ALT
include a tool for finding the distribution that best fits the data for the selected
data set.

1. Select LDA » Find Best Fit Distribution. The Best Fit Distribution window opens
and shows all available failure distributions on the Analysis page. You can
select which distributions you want to check against the data set. In this case,
leave all distributions selected.

2. Click Analyze. A ranking for each distribution appears in the Rank column.

Depending on your data set, the recommended distribution might not be the
distribution currently selected for the data set. For example, the current
distribution is Weibull (2 Parameters), and the recommended distribution for
this randomly generated data set might be Weibull (3 Parameters). If this is the
case, the Change button is shown at the bottom of the window, along with a
prompt asking whether you want to change the current distribution setting to
the recommended distribution.

For this example, if the Change button is shown, ignore it so that the this
Weibull (2 Parameters) distribution remains in use.
3. Click Close.

Understanding Weibull Calculations

Calculations, which in PTC Windchill Weibull are performed dynamically for life
data sets, are based on the distribution specified. In the case of the Weibull
distribution, the Weibull module calculates the following results:

* B — The Beta value is the slope of the line.

» n — The Eta value is the characteristic life, which is the point at which 63.2%
of the items in the data set have failed.

* p— The Rho value is a value between -1 and 1 that expresses how well the
data fits the probability line.

¢ p? — The Rho-squared value is the 10th percentile of the correlation
coefficient.

In the lower left window, you can view these calculated values in the Calculation
results area in panes in which you specify analysis parameters.
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Viewing Weibull Plots

When you analyze life data sets, PTC Windchill Weibull automatically generates
and displays the resulting Weibull plots in the Weibull Plot pane on the right.
These plots are updated dynamically as you make changes. So, for example, if you
change the distribution, the plot is updated to display the newly selected
distribution.

To view the resulting Weibull plot:
1. In the window on the right, select the Weibull Plot pane.

You can learn many things by examining a Weibull plot. For example, if
points are concentrated in one particular area, a batch problem might have
occurred due to production or assembly processes, maintenance or overhaul
schedules, or increases in service usage.

Sharper corners or dogleg bends, on the other hand, might indicate multiple
competing failure sources. For example, many components have a high infant
mortality due to production and quality problems, and then they have another
group of failures later in life when they begin to wear out. In this case, you
might want a separate Weibull plot for each failure mode, treating the data
points for other failure modes as suspensions. As noted earlier, Weibull
analysis is most effective when each data set concentrates on one failure mode.

You can also use the plot to determine if the distribution selected fits your data
well. For example, if the failure data points curve in comparison to the best fit
line, then the selected distribution probably was not the best fit for the data. To
determine a distribution with the best fit, you can perform best fit distribution
analysis.

2. Determine the B10 life, which is the time at which 10% of the items in the
data set have failed. To do so, place your cursor at the point where the plot line
intersects the horizontal line at 0.10 Probability. A tooltip indicates the
probability value at a specified time. Your time varies, depending on the
random data points that were generated.

Probability Line

Time: 3.953894
Probability: 0. 112756

Probability
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o Tip
You can always zoom in on a specific area of the plot by holding down the

left mouse button and drawing a selection box around the area you want to
view more closely. To reset your zoom, right-click and select Reset Zoom.

Customizing Plots

Weibull plots are very easy to customize. When a plot is active, you can open the
Plot Properties window and change the plot colors, labels, and fonts to suit your
needs.

I.
2.

Select the Weibull Plot pane.

Right-click in the plot and select Edit Plot Properties. The Plot Properties
window opens.

On the General page, change Title to My Weibull Plot.
For Legend location, select Inside Movable.

In the left pane, select the Axis page. Here you can change the range of your
axes, as well as specify a minimum and maximum value. Leave the default
values.

In the left pane, select the Color page.

7. Under Style, for Quickstyle, select Light Line. This property applies a

10.

11.

predefined set of colors to the plot and its background.

If you select Default or No Style, you can specify color preferences for some or
all properties under Color using color controls.

In the left pane, select the Series Colors page. This page enables you to set the
colors of each plot line when plotting multiple data sets.

In the left pane, select the Font page and then the Font Size page.

On these pages, you can set specific fonts for the titles and plot labels. You can
also adjust the sizes of all fonts using the slider bars and preview the resulting
changes as you make adjustments.

Click OK to update your plot.

The title is now My Weibull Plot, the color palette has changed, and the legend
is in the top left corner rather than in the center right. Because you specified
that the legend was to be moveable, you can drag it wherever you like.

Place your mouse pointer over the legend until the cursor changes to a hand.
Select the legend and drag it to the bottom right of your plot.
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Viewing Plots for Multiple Data Sets

When you select the Multiple Data Sets folder in the LDA Navigator, you can plot
data sets with similar parameters and the same distribution simultaneously on the
same graph. You can use this type of plot to compare any number of things,
including:

» Data sets from different failure modes for the same product

» Data sets collected at different operating conditions, such as circuit board test-
to-failure data at both 50 degrees C and 60 degrees C

» Data sets of similar products, such as failure data for bearings from different
suppliers

* Data sets from different time frames, such as those from the past five calendar
years

» Data sets collected from a system before and after a redesign

In this case, you view data sets for a hard disk before and after a redesign.
To view both hard disk data sets on one plot:

1. Select the LDA Navigator.

2. Under Analysis type, ensure Life Data is selected.

3. Under Data sets, select Multiple Data Set Plots.
4

Select Insert » Multiple Data Set Plot. A new data set row appears in this
folder.

This new data set, which is named Multiple Data Set Plot by default, is
automatically selected.

Enter My Weibull Multiple Data Set Plot.

In the Weibull Plot Options pane, click Select All to select the two revisions
listed for the hard disk.

The plot in the Weibull Plot pane plots both data sets. If you select only some of
data sets available in the Weibull Plot Options pane, you can always go back and
select them to add them to the plot.

Viewing a Weibull Report

To view a Weibull report:
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In the Project Navigator, under Reports > Weibull Reports, select (Common)
Weibull Life Data. Because the two reports in this Report Binder file require

input data, the Report Properties window opens.

For the top report, do the following:

a. Under the Record selection heading, if Hard Disk Revision A is not already
selected for Weibull Data Set, click I:I to select it.

b. Verify that the Apply this selection to all reports checkbox is selected.

For the other report, you can use the default values.

Click OK to generate the report and open it in a preview window.

You can use the toolbar in this window to print your report, move through its
pages, switch between a two-page and one-page view, zoom in and out, and
close this window.

When finished viewing the report, do one of the following to close the
window:

* Select Preview » Close.

*  Click the close button on the toolbar.

Additional Weibull Features

PTC Windchill Weibull includes a number of additional functions and features. A
brief listing of other topics of interest is shown below. For more information about
these features, see the help or guide for PTC Windchill Quality Solutions.

You can specify a threshold parameter, which is also known as a location
parameter or minimum life parameter, to set a minimum life value for the
failure data set, signifying a guaranteed failure-free period at the beginning of
the cycle. Typically used with the Weibull distribution, a threshold parameter
straightens a plot of data values if the data shows a pronounced curve
compared to the failure distribution line.

You can perform reliability growth analysis, which tracks the increase in the
reliability of a product over time. By tracking reliability, mean life, or failure
rate over time, you can predict future reliability values based on the current
rate of growth of the measurement of interest. Weibull module uses the Duane/
Crow-AMSAA model to perform reliability growth analysis.

You can analyze data without specifying an underlying distribution using non-
parametric life data analysis. The Weibull module supports the Kaplan-Meier
and standard actuarial methods.
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You can perform degradation analysis, which forecasts future failures based on
measurements of degradation or performance over time. The Weibull module
supports six degradation models, including Linear, Exponential, and Power.

You can use the General Statistics Calculator to run a number of different
statistical calculations, including Binomial, Chi-Squared, Life-Usage
Interaction, Mean and Eta, Poisson, Random Point Interaction, Strength-Load
Interaction, and Student T.

You can use the Test Planning Calculator to determine the number of
components to test or the amount of time for which to test. The Test Planning
Calculator supports three methods: Parametric Binomial, Non-Parametric
Binomial, and Exponential Chi-Squared.

You can use the Summary Calculator to perform additional calculations on
data sets that are analyzed based on parametric distributions. This applies to
all but non-parametric life data sets. These additional calculations include
Standard Probability, Conditional Probability, Failure Rate, Warranty Time,
Time to Failure, and more.

You can use the Optimal Replacement Wizard to optimize your component
replacement strategy based on minimizing system downtime or the overall
cost of the system over the long term.

You can link Weibull data to items inPTC Windchill Prediction and PTC
Windchill RBD to make the results calculated for reliability predictions and
block diagrams more accurate.
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This section of the PTC Windchill Quality Solutions Getting Started Guide
provides basic information about accelerated life testing and how to accomplish it
using PTC Windchill ALT.

In this section, you create a new data set in the ALT module, run calculations, and
view the resulting graph.

~ Note

Because Projects can be fully customized, your screens might not look like the
ones shown in this guide.
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ALT Overview

ALT (accelerated life testing) is a technique for speeding up product testing so that
you can find the reliability characteristics of a product more quickly. To apply
ALT techniques, you test products in high-stress situations that typically shorten
product life or hasten degradation of product performance. With such tests,
“stress” refers to any accelerating variable.

By statistically fitting an acceleration model to the test data and extrapolating the
fitted model, you can estimate the life or degradation of the product at the lower
stress levels encountered in normal use. Thus, accelerated testing plays a key role
in meeting the requirements of shorter product development cycles.

This technique is especially useful for determining or demonstrating the field
reliability performance of highly reliable products. When tested under stress levels
encountered during normal use, products with high reliability last so long, or
degrade so little, that their performance and lifetime are very difficult to estimate.
Accelerated testing yields reliability estimates of such products in a much shorter
time.

In a simple situation, the components under test are divided into multiple groups
containing one or more components. Each component is tested at specific
combinations of stress levels. You enter the failure and suspended times
corresponding to the stress levels in the software.

If the stresses on the component are constant with respect to time, the tests are
known as constant stress tests. In some cases, the stresses are increased with time
so that the test can be completed within a predetermined time with some failures.
You record variations in the stresses in stress profiles.

For further information, see the following references.

*  Meeker, William Q., and Escobar, Luis A., Statistical Methods for Reliability
Data, John Wiley & Sons, Inc., New York, 1998

* Meeker, William Q., A Comparison of Accelerated Life Test Plans for Weibull
and Lognormal Distributions and Type I Censoring, Technometrics, Vol. 26,
No. 2, pp. 157-171, 1984

* J. E. Dennis, Jr. and Robert B. Schnabel, Numerical Methods for
Unconstrained Optimization and Nonlinear Equations, Classics in Applied
Mathematics 16

* Numerical Recipes: C++ Version (2007)
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Getting Started with PTC Windchill ALT

If PTC Windchill Quality Solutions is started and the Tablet PC
System file is open

If you are already using PTC Windchill Quality Solutionsand your Project with
the Tablet PC System file is open, you can enable the ALT module. For more
information, see Enabling PTC Windchill ALT on page 117.

If PTC Windchill Quality Solutions is not started

If PTC Windchill Quality Solutions is not started, then start it. For more
information, see Starting PTC Windchill Quality Solutions on page 10.

If your copy of the Tablet PC System file is not open

The Tablet PC System file in your My Tablet PC Project is used to demonstrate
module features in this guide. If this System file is not open, then open it by doing
one of the following:

+ If'the Recent Files control on the Start Page lists the Tablet PC System file in
the My Tablet PC Project, click this file name to open the file.

 If the Project Navigator shows a listing of your Projects and Systems (you see
a Click a file to open link), click Tablet PC under My Tablet PC to open the
System file.

» If the Project Navigator shows that a different Project is open (you see a name
other than My Tablet PC after the Project: label):
1. Close all open files by clicking < Click to close Project >.
2. Under My Tablet PC, click Tablet PC to open the System file.

» If the Project Navigator has the My Tablet PC Project open (you see Project: My
Tablet PC in the Project Navigator), click Tablet PC under the Systems heading
to open this System file.

Enabling PTC Windchill ALT

On the Module Selections toolbar, select the ALT button © and deselect all other
module buttons.

The System file displays only PTC Windchill ALT panes. For both this module
and the Weibull module, a three-window interface is used. The upper left window
displays the LDA Navigator, which you use to select an analysis type and manage
data sets.
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LDA Navigator

The LDA Navigator displays your list of data sets. When you select a data set in the
LDA Navigator, the other two windows in the System file display information
specific to this data set.

Data sets are organized by analysis types. Under Analysis type, you click the type
of data sets you want to view.

For the ALT module, two analysis types are available:

* Accelerated Life Testing — Consists of parametric life data sets, non-
parametric life data sets, and reliability growth data sets. You can also insert
data sets for plotting multiple data sets concurrently on a plot.

* Accelerated Degradation — Consists of degradation analysis sets, which use
the changing rate of degradation of a product and a critical value at which the
unit is assumed to fail to create a model for predicting the times at which the
product will fail in the future. You can also extrapolate a life data set from
degradation information and analyze it using typical life data analysis
techniques.

In the LDA Navigator, you can create new data sets and delete data sets you no
longer need. You can also further organize the data sets for any analysis type by
creating subfolders.

ALT Parameters

The window beneath the LDA Navigator contains one or more panes, depending on
the selected analysis type.

* When Accelerated Life Testing is selected, this window contains different
panes, depending on the folder selected under Data Sets. When the Life Data
folder is selected, two panes are available: Parameters and Plot Options

*  When Accelerated Degradation is selected, the same two panes are available.

These two panes display analysis parameters and plot options.

* Parameters — Specifies parameters for analyzing the selected data set.

* Plot Options — Specifies the number and type of plots to display in the ALT
Plot pane in the window on the right.

When a life data set is calculated, results display at the bottom of the Parameters
pane, in this Calculation results area. Here, you can specify a fixed value for a
particular calculated value if you want. The results shown depend on the
distribution selected.
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All panes in the lower right window display toolbar buttons on the right side of
the title bar. Buttons are available only when they are applicable to the active data
set.

You can click these toolbar buttons to perform common tasks, including:

» Calculating the active data set
» Showing the plot for the active data set
* Opening the Summary Calculator window to perform additional calculations

* Running best fit distribution analysis

ALT Data Points

When a life data set is selected in the LDA Navigator, the window to the right
contains three tabbed panes: ALT Data Points, ALT Results, and ALT Plot.

* ALT Data Points — Displays the data you want to analyze.

* ALT Results — Displays results once the data set is calculated. The results
shown depend on the selections made on the panes in the lower left window.

* ALT Plot — Displays a plot for the data set and the one or more distributions
applied to it. The parameters, distribution, and number of plots shown depend
on selections made on the panes in the lower left window.

¢ Tip
You can modify the column heading in the ALT Data Points table to suit your
process needs. Simply double-click the column heading and then specify the
desired name in the Change Column Name window that opens.

Using PTC Windchill ALT

You now create a data set, enter data points, and find the distribution that best fits
your data points. After viewing and modifying the plot, you generate a report.

Creating a New Data Set

In this section, you create a random data set and then specify a stress model and
stresses. The stress levels that you use for testing should accelerate the failure
modes under consideration, but they should do not introduce failure modes that
would never occur under normal use conditions. Generally, stress levels fall
outside the product specification limits but inside the design limits. If you do not
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know what stresses or limits to use, you can perform multiple tests with small
sample sizes to ascertain those that are appropriate. In this case, you specify only
one stress, which is operating temperature.

To create a new data set:

1. Inthe LDA Navigator, under Analysis type, click Accelerated Life Testing to
ensure you are viewing data sets for this type of analysis.

2. Under Data sets, select the Life Data folder.

3. Select Insert » ALT Data Set. A new data set named ALT Data Set is inserted
in the folder. It is already selected.

4. Enter My ALT Data Set as the name of this data set.
Select the Parameters pane in the lower left window.

6. Leave the default values.

ALT Parameters EE
Data type: | Exact Times - |

[ suspensions [] Grouped
Distribution: [Weibull - J
Stress: Constant

Life stress model: Arrhenius

[ Stress Model I

7. Click Stress Model. The Stress Model window opens.

In the first row of the table, select the Stress 1 value for Name and enter
Temperature.

9. For Usage Stress, enter 310.
10. For Default Value, enter 350.
11. Click OK to close the Stress Model window.

Entering Data Points

Once the analysis parameters are specified, you enter data points in the ALT Data
Points table. You can either specify the data points manually, or you can copy and
paste them from a word-processing file, spreadsheet, or other electronic file.

For this example, you use the built-in random data point generator to create a set
of data points. In actual use, you would not create a data set in this manner. It is a
feature available for testing and sample data generation.

120 Getting Started Guide



»

A S B

Select the ALT Data Points pane.

Select LDA » Generate Random Data Points. The Generate Random Data

Points window opens.
For B, enter 6.

For B, enter 17000.
For C, enter 3.0e-12.

In the table on the right, click < Click here to insert a stress level >.

For Quantity, enter 2.

For Temperature, enter 4 93.

Repeat steps 6 through 8 to insert the following stress records.

Quantity Temperature
4 513
5 533

10. Click OK to generate the random data points.

Running Calculations in PTC Windchill
ALT

Calculations determine the parameters for the selected life stress model. The

parameters to calculate depend on the distribution specified. Because automatic

data set calculation is turned off for the ALT module by default, you must
manually run these calculations.

To calculate ALT results:

1.

Select System » Calculate, or click the calculate [

toolbar. The Calculate window opens.

button on the standard

In the left pane, select the Calculation Selection page if it is not already

selected.

In the right pane, click Clear All and then select ALT to run calculations only

for the ALT module.
In the left pane, select the ALT page.

PTC Windchill ALT
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5. Select Selected data set only and click OK. When completed, the View
Calculation Results window opens.

You can print your calculation results by clicking Print in the View

Calculation Results window. You can also save them to a Microsoft Excel
spreadsheet by clicking Excel.

6. Click Close when you have finished reviewing results.

These same results are also shown on the ALT Results pane. In the right pane,
select this pane so that you can see the same results.

Viewing ALT Plots

After performing calculations, the resulting ALT plots are generated and can be
viewed in the ALT Plot pane. Because plot parameters are based on stress
parameters, you must recalculate if you change the distribution, stress type, or
stress model.

To view the resulting ALT plot:
In the lower left window, select the Plot Options pane.
2. For Plot type, sclect Acceleration Factor vs Stress.
In the window on the right, view the plot in the ALT Plot pane.

This plots displays the acceleration factor with respect to the defined
temperature stress. If you had added other stresses, they would have been
considered fixed at the usage stress levels.

You can always zoom in on a specific area of the plot by holding down the
left mouse button and drawing a selection box around the area you want to
view more closely. To reset your zoom, right-click and select Reset Zoom.
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Viewing an ALT Report

1.

In the Project Navigator, under Reports > ALT Reports, select (Common)
Accelerated Life Testing. Because the two reports in this Report Binder file

require input data, the Report Properties window opens.
For the top report, under the Record selection heading, if Hard Disk Revision D
is not already selected for ALT Data Set, click I;I to select it.

For the other report, you can use the default values.
Click OK to generate the report and open it in a preview window.

You can use the toolbar in this window to print your report, move through its
page, switch between a two-page and one-page view, zoom in and out, and
close this window.

When finished viewing the report, do one of the following to close the
window:

¢ Select Preview » Close.

*  Click the close button on the toolbar.

Additional ALT Features

PTC Windchill ALT includes a number of additional functions and features. A
brief listing of other topics of interest is shown below. For more information, see
the help and guide for PTC Windchill Quality Solutions.

You can perform analysis based on both constant and time-varying stresses
using the Weibull, lognormal, and exponential distributions.

You can use all common accelerated life testing models, including Arrhenius,
Eyring, Inverse Power Law, Temperature-Humidity, Temperature-
NonThermal, Generalized Eyring, Proportional Hazards, and General Log-
Linear.

You can perform accelerated degradation analysis, which forecasts future
failures based on measurements of degradation or performance over time. The
ALT module supports six degradation models, including Linear, Exponential,
and Power.

You can generate many different plot types and also even compare and
contrast multiple plots. Additionally, you can perform best fit distribution
analysis and use the Summary Calculator to perform additional calculations on
parametric life data sets.

PTC Windchill ALT 123






11

PTC Windchill Maintainability

Maintainability Prediction OVEIVIEW............cooiiiiiiii i 126
Getting Started with PTC Windchill Maintainability ... 126
Using PTC Windchill Maintainability ..............c.ccoooiiiiiiii e 127
Understanding Maintainability Calculations ..o 129
Viewing Maintainability REPOIS ........coouiiiii e 133
Additional Maintainability Features ...............oi i 133

This section of the PTC Windchill Quality Solutions Getting Started
Guideprovides basic information about maintainability predictions and how to
perform them using PTC Windchill Maintainability.

In this section, you review and enter data in the Maintainability module, run
calculations on that data, and view a report.

~ Note
Because Projects can be fully customized, your screens might not look like the
ones shown in this guide.
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Maintainability Prediction Overview

Maintainability predictions provide metrics related to the repair of equipment. The
main goal of performing a maintainability prediction is to determine the amount of
time required to perform repairs and maintenance tasks, so that you are aware of
the time it would take and what tasks would be required to bring the system back
to an operable state after a failure.

The main metric in maintainability predictions is MTTR (mean time to repair),
which various maintainability analysis procedures compute in different ways.
Various other repair metrics are important as well, such as MCMT (mean
corrective maintenance time) and MPMT (mean preventive maintenance time).

MTTR influences system availability, which is the measure of the likelihood that a
system is in an operable state. In many industries, availability is a key measure of
system performance, so having an accurate measurement of this metric is crucial.
Also, availability can be a metric to verify if the system, as designed, would meet
operational requirements.

Maintainability predictions can also help you to identify areas of poor
maintainability, which might justify a change in design and/or repair procedures.

To complete a maintainability prediction, you must have failure rate data for the
repairable items and data regarding the tasks and associated times to complete
repairs. Maintainability predictions are often performed based on established
standards. One of the most prominent is MIL-HDBK-472, specifically procedures
2, 5A, and 5B.

If you are unfamiliar with maintainability predictions and would like to study this
topic in more detail, refer to MIL-HDBK-472.

Getting Started with PTC Windchill
Maintainability

If PTC Windchill Quality Solutions is started and the Tablet PC
System file is open

If you are already using PTC Windchill Quality Solutions and your Project with
the Tablet PC System file is open, you can enable the Maintainability module. For
more information, see Enabling PTC Windchill Maintainability on page 127.

If PTC Windchill Quality Solutions is not started

If PTC Windchill Quality Solutions is not started, then start it. For more
information, see Starting PTC Windchill Quality Solutions on page 10.
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If your copy of the Tablet PC System file is not open

The Tablet PC System file in your My Tablet PC Project is used to demonstrate
module features in this guide. If this System file is not open, then open it by doing
one of the following:

» If the Recent Files control on the Start Page lists the Tablet PC System file in
the My Tablet PC Project, click this file name to open the file.

+ If the Project Navigator shows a listing of your Projects and Systems (you see
a Click a file to open link), click Tablet PC under My Tablet PC to open the
System file.

» If the Project Navigator shows that a different Project is open (you see a name
other than My Tablet PC after the Project: label):

1. Close all open files by clicking < Click to close Project >.
2. Under My Tablet PC, click Tablet PC to open the System file.

» If the Project Navigator has the My Tablet PC Project open (you see Project: My
Tablet PC in the Project Navigator), click Tablet PC under the Systems heading
to open this System file.

Enabling PTC Windchill Maintainability

On the Module Selections toolbar, select the Maintainability button “ and
deselect all other module buttons.

The System file displays only PTC Windchill Maintainability panes.

Using PTC Windchill Maintainability

The top window contains two tabbed panes:

* System Tree Items — Displays the hierarchical breakdown of your system and
is shared with several modules.

* Problems — Displays a list of problems and is shared with several other
modules.

The bottom window also contains two tabbed panes:

* Problems Form — Displays a sample form for entering data for the active
problem in the Problems table.

* Maintainability Data — Displays all maintainability specific data for the
assembly or part selected in the system tree.

For this example, you begin by reviewing and entering maintainability data. You
then learn about Maintainability Task Library files.
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Reviewing and Entering Maintainability Data

In the System Tree Items table, you select an assembly or part so you that you can
view and modify the repair data and repair tasks entered for this item in the
Maintainability Data pane below.

1. In the System Tree Items table, select the following assemblies and review the
data shown in the Maintainability Data pane:

*  Motherboard
*  Touchpanel
*  Memory Board

2. Now select Hard Disk Assembly. Currently, no data is present in the
Maintainability Data pane.

3. In the Repair tasks table, click < Click here to insert a new record > to insert
the first task.

For Task Code, select Remove HD Assy.

To insert a second task, click < Click here to insert a new record > again and for
Task Code, select R/R Hard Disk.

~ Note
R/R stands for “Remove and Replace.”

6. To insert the third and final task, click< Click here to insert a new record >
again and for Task Code, select Replace HD Assy.

On the upper right side of the pane, the following display-only fields are updated:
Totals, Number of items, Total time (Mct), and Manminutes. PTC Windchill
Maintainability pulls in the times for performing the three repair tasks that you
inserted from Maintainability Task Library files.

Maintainability Task Library Files

You can retrieve repair data from either Maintainability Task Library files or
Maintainability FD&I Output files. For this example, the repair data was retrieved
from a Maintainability Task Library file.

To view the Maintainability Task Library file for this sample Project:
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1. In the Project Navigator, click Expand files to display all support files.

~ Note

If this command is not available, click Collapse files and then click Expand
files.

2. Under Support Files > Maintainability > Task Library, select Maintainability Task
Library. This file opens.

3. In the Tasks pane on the left, select various tasks to see the repair data for
these tasks in the pane on the right.

When finished, select File » Close to close this file.
In the Project Navigator, click Collapse files to hide all support files.

Understanding Maintainability
Calculations

PTC Windchill Maintainability computes a number of maintenance-related values,
such as MTTR (mean time to repair), MCMT (mean corrective maintenance
time), and MPMT (mean preventive maintenance time).

A sampling of supported calculations is outlined below and brief descriptions are
provided.

~ Note

Some of these calculations reference preventive maintenance and/or corrective
maintenance. Corrective maintenance restores a failed system to operational
status by repairing or replacing failed components. Preventive maintenance is
the practice of replacing components or subsystems before they fail to
promote continuous system operation.

For more information about these calculations, see the guide or help for PTC
Windchill Quality Solutions.
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Calculation Description

Maintainability index |The total maintenance effort, including both preventive
and corrective maintenance, that is required to maintain
a product in operational status during a specific time
period. The maintainability index is calculated based on
MIL-HDBK-472 Procedure 2. This calculation uses the
values from both (1) and (2) of the MAMT (mean active
maintenance time) calculation.

MTTR The average time it takes to repair a failed unit and
return it to an operational state, based on the average
repair time for its replaceable components. The MTTR
(mean time to repair) is calculated by rolling up the
average repair times for lower-level components to
compute subassembly and system repair values. Units
for MTTR values are typically hours or minutes. MTTR
is also referred to as MCT (mean corrective time).

o Tip
If you use this module in conjunction with PTC
Windchill Prediction, you can use the
Maintainability-computed MTTR values for
components in your reliability prediction.

Availability The probability that a system is operating properly at a
specific time point. Availability, like reliability, is a
time-based probability metric between 0 and 1.
Availability is a function of both reliability (how
quickly a system fails) and of maintainability (how
quickly the system can be repaired).

Mean corrective The mean time required to perform all corrective
maintenance time maintenance actions. The MCMT is the average time
(MCMT) required to restore a failed system to operational status
by repairing or replacing failed components.
Mean active The average time required to perform all corrective and
maintenance time preventive maintenance actions. The calculation is taken
(MAMT) from MIL-HDBK-472 Procedure 2.
Max corrective The time needed to accomplish the specified percentage
maintenance time of potential corrective maintenance tasks, frequently the
(MAXCMT) for sigma |90th or 95th percentile. For example, if you specify a
percentile value of 90, the MAXCMT is the time within which

90% of all maintenance actions can be accomplished.
The calculation is taken from MIL-HDBK-472,
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Calculation

Description

Procedure II1.

Mean maintenance
manhours per repair
(MMH/Repair)

This calculation is identical to the MTTR calculation
except manhour values are substituted for time values.

Mean maintenance
manhours per
maintenance action
(MMH/MA)

This calculation is similar to the MMH/Repair
calculation except that the time spent as a result of false
alarms is also taken into account.

Mean maintenance
manhours per
operating hour (MMH/
OH)

The sum of all corrective, preventive, and false alarm
repair times divided by the total operating hours.

Mean maintenance
manhours per flight
hour (MMH/FH)

The sum of all corrective, preventive, and false alarm
repair times divided by the total flight hours.

Mean preventive

maintenance time
(MPMT)

The mean time required to perform all preventive
maintenance actions. The MPMT is the average time
required to replace components or subsystems before
they fail to promote continuous system operation. The
calculation is taken from MIL-HDBK-472 Procedure 2.

Percent isolation to a
single replaceable item

The percentage of faults detected that can be isolated to
a single replaceable item.

Percent isolation to a
group of replaceable
items

The percentage of faults detected that can be isolated to
n or fewer replaceable items, where n is a specified
quantity.

Running Maintainability Calculations

To calculate Maintainability results:

1. Select System » Calculate, or click the calculate [&

button on the standard

toolbar. The Calculate window opens.

2. In the left pane, select the Calculation Selection page if it is not already

selected.

3. In the right pane, click Clear All and then select Maintainability to run
calculations only for the Maintainability module.

4. In the left pane, select the Maintainability page.

A number of calculations are available.

PTC Windchill Maintainability

131




5.

6.

7.

132

Leave the default values.

"« Maintainability Calculation Options

Repair level: -

[| Percent isolation to a single replaceable item
[]Percent isolation to & group of replaceable items

[¥]| Mean maintenance manhours per repair (MMH,Repair)

[¥]Mean maintenance manhours per maintenance action (MMH/MA)
Mean maintenance manhours per operating hour (MMHOH)

[ Mean maintenance manhours per fight hour (MMH/FH)

a

D Max corrective maintenance time for sigma percentile
]

E Mean corrective maintenance time

|_~_-I'] Mean preventive maintenance time

|:| Mean active maintenance time
[ maintainability index

Click OK to run the calculations. When the calculations are complete, the View
Calculation Results window opens.

Values that are not calculated display a value of #.#. These are calculations
you did not select on the Maintainability page in the Calculate window.

¢ Tip
You can print your calculation results by clicking Print in the View
Calculation Results window. You can also save them to a Microsoft Excel
spreadsheet by clicking Excel.

Click Close when you have finished reviewing results.
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To display the results again at any time, you would select System » View
Calculation Results. If you have only one module enabled, the results shown are
only for this module. If multiple modules are enabled, a navigation pane is shown
so that you can select the results you want to view.

Viewing Maintainability Reports
1. In the Project Navigator, under Reports > Maintainability Reports, sclect

(Common) Maintainability Standard to generate this report and open it in a
preview window.

This report outputs basic maintainability information about the system and its
components, including item names, part numbers, reference designators,
quantities, and calculated results for failure rate, MMH/OH (mean
maintenance manhours per operating hour), and MTTR (mean time to repair).

You can use the toolbar in this window to print your report, move through its
page, switch between a two-page and one-page view, zoom in and out, and
close this window.

2. When finished viewing the report, do one of the following to close the
window:

* Select Preview » Close.

* Click the close button on the toolbar.

Additional Maintainability Features

PTC Windchill Maintainability includes a number of additional features and
functions. A brief listing of other topics of interest is shown below. For more
information about these features, see the help or guide for PTC Windchill Quality
Solutions.

* You can use Maintainability Tasks Library files to store standard maintenance
tasks and repair time so that they can easily be copied into any maintainability
prediction. While a supplied Maintainability Tasks Library contains the task
data from MIL-HDBK-472, you can create any number of your own files.

* You have the option of performing maintainability calculations based on MIL-
HDBK-472 Procedure 2, 5A, or 5B standards.

* You can use Maintainability Groups files to perform MIL-HDBK-472
Procedure 5A calculations.

*  You can link items in your maintainability prediction with items in other
modules such as PTC Windchill Prediction and PTC Windchill RBD.
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* You can use default repair levels or defined your own custom repair levels.

* You can export maintainability data to LSAR compatible formats.
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This section of the PTC Windchill Quality Solutions Getting Started Guide
provides basic information about Markov analysis and how to perform one using
PTC Windchill Markov.

In this section, you review Markov state properties and create a simple Markov
diagram. You then run calculations and view a standard report and graph.

' Note

Because Projects can be fully customized, your screens might not look like the
ones shown in this guide.
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Markov Analysis Overview

Markov analysis is a technique used to study dynamic system behavior. In terms
of all reliability analysis techniques, Markov analysis is the only method you can
use to accurately model complex systems that include common cause failures,
imperfect coverage, shared load redundancy, complex repair policies, degradation,
shock effects, induced failures, dependent failures, and other sequence-dependent
events. While you can use other modeling methods, such as fault trees and RBDs
(reliability block diagrams), to model some of these unique system complexities,
Markov analysis provides the broadest capabilities in terms of handling diverse
system characteristics.

To complete a Markov analysis, you must construct a Markov diagram, which is
also known as a state transition diagram. This diagram is a graphical
representation of the system's operational, degraded, and failed states as well as
the transitions between these states. Most commonly, transition rates are failure
rates or repair rates. The Markov diagram ultimately represents the system as a set
of random variables with interdependencies. The results of a Markov analysis can
include reliability, availability, MTBF, and failure rate.

If you are unfamiliar with Markov analysis and would like to study this topic in
more detail, the following is an excellent resource:

» Reliability: A Practitioner's guide (Chapter 8)

Getting Started with PTC Windchill
Markov

If PTC Windchill Quality Solutions is started and the Tablet PC
System file is open

If you are already using PTC Windchill Quality Solutions and your Project with
the Tablet PC System file is open, you can enable the Markov module. For more
information, see Enabling PTC Windchill Markov on page 137.

If PTC Windchill Quality Solutions is not started

If PTC Windchill Quality Solutions is not started, then start it. For more
information, see Starting PTC Windchill Quality Solutions on page 10.
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If your copy of the Tablet PC System file is not open

The Tablet PC System file in your My Tablet PC Project is used to demonstrate
module features in this guide. If this System file is not open, then open it by doing
one of the following:

» If the Recent Files control on the Start Page lists the Tablet PC System file in
the My Tablet PC Project, click this file name to open the file.

+ If the Project Navigator shows a listing of your Projects and Systems (you see
a Click a file to open link), click Tablet PC under My Tablet PC to open the
System file.

» If the Project Navigator shows that a different Project is open (you see a name
other than My Tablet PC after the Project: label):

1. Close all open files by clicking < Click to close Project >.
2. Under My Tablet PC, click Tablet PC to open the System file.

» If the Project Navigator has the My Tablet PC Project open (you see Project: My
Tablet PC in the Project Navigator), click Tablet PC under the Systems heading
to open this System file.

Enabling PTC Windchill Markov

On the Module Selections toolbar, select the Markov button @2 and deselect all
other module buttons.

The System file displays only PTC Windchill Markov panes.

Using PTC Windchill Markov

The top window contains the Markov Table pane, and the lower window contains
the Markov Diagram pane.

* Markov Table — Displays all Markov diagrams in the System file.
* Markov Diagram — Displays the Markov diagram selected in the table.

The states of the Markov diagram are represented by colored shapes. The
transitions between states are represented by the arrows connecting two states
together.

For this example, you begin by reviewing state and transition properties. You then
create a simple Markov diagram.
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Reviewing Markov State and Transition Properties

For ease of viewing, you can resize the Markov Diagram pane using the splitter
control, which appears when you place the mouse cursor between the two panes.
If horizontal and/or vertical scroll bars are present in the Markov Diagram pane,
you can use them to view hidden parts of the diagram.

Finally, you can zoom in and out by right-clicking in an empty area of the diagram
and selecting a zoom option. Or, you can press and hold down the Ctrl key while
rotating your mouse wheel.

This sample Markov diagram is modeling the sequence of events leading to a
memory failure. The memory begins in an operational state. If one SRAM SIM
fails, the tablet PC operates in a degraded mode. If all three SRAM SIMs fail, the
tablet PC fails.

1. In the Markov Diagram pane, double-click State5. The Calculation Properties
window for this state opens.

On the General page, you set one of three conditions for the state: Good,
Failed, or Degraded.

If you want to calculate costs, you can also associate a gain or loss that occurs
when the system is in this state.

2. In the left pane, select the Results page. This page displays the most recent
calculated results for this state. If calculations are not yet available, this page
is empty.

3. Click Cancel to close the window for the state.

Select Markov > View States. The Markov States window opens. It displays all
of the states currently in the diagram. In this window, you can edit the data for
all states in one place, which is useful when you have a large Markov diagram
and need to manage many states.

Click Close to close the Markov States window.

6. Place the mouse cursor over the left-most black arrow between State5 and
State10 until the cursor changes to a four-sided arrow; then, double-click.

The Calculation Properties window for this transition opens. On the General
page, you see that a rate of 0.125 is set.

7. In the left pane, select the Results page. This page displays the most recent
calculated results for this transition. If calculations are not yet available, this
page is empty.

Click Cancel to close the window for the transition.

Select Markov » View Transitions. The Markov Transitions window opens. It
displays all of the transitions currently in the diagram.
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In this window, you can edit the data for all transitions in one place, which is
useful when you have a large Markov diagram and need to manage many
transitions.

10. Click Close to close the Markov Transitions window.

Creating a Simple Markov Diagram

You have seen what a Markov diagram looks like in PTC Windchill Markov. Now
you can create a simple diagram:

1. Select the Markov Table.
2. Click < Click here to insert a new record > to insert a new diagram.

3. For Identifier, enter My Markov Diagram. An initial state is already inserted
in the diagram for you.

4. Select the Markov Diagram pane.
Select Insert » State. The Insert State window opens.

6. Click OK to insert a state with the default style. When you move the mouse
cursor in the diagram pane, it changes into the shape of the selected state style.

7. Move the cursor to the right of the initial state and click the mouse button to
insert a state.

The cursor remains in the shape of the state style to let you know that you can
continue to insert states, if desired.

Right-click to exit the insertion mode.
Select Markov > Auto Connect States to automatically connect the states.
10. Double-click the top transition line to open the Properties window.

11. For Rate, enter 0. 00015 to indicate a failure rate of 0.00015 failures per
hour; then, click OK.

12. Double-click the bottom transition line to open the Properties window.

13. For Rate, enter 12 . 5 to indicate a repair rate of 12.5 repairs per hour; then,
click OK.

14. Double-click the right-most state to open the Properties window.
15. For State, select Failed; then, click OK.

This simple diagram models a system that begins in an operational state. Because
it has a failure rate of 0.00015 failures per hour, the system eventually reaches the
failed state. With a repair, which occurs at the rate of 12.5 repairs per hour, the
system returns to the operational, or good, state.
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Understanding Markov Calculations

PTC Windchill Markov computes an extensive set of reliability related values. A
sampling of supported calculations is outlined below and brief descriptions are
provided. For more information about these calculations, see the help or guide for
PTC Windchill Quality Solutions.

Calculation

Description

Availability

The probability that a system is operating properly at a
specific time point. Availability is a time-based probability
value, so it is always a value between 0 and 1. Itis a
function of both reliability (how quickly a system fails)
and of maintainability (how quickly the system can be
repaired).

Capacity

The average throughput, profit, or reward of the system per
unit time at a specified point in time.

MTBF

The MTBF (mean time between failures) represents the
number of hours a unit operates between failures.

Mean time to first
failure (MTTFF)

The average time until the first failure of the system.
Frequently, MTTFF is simply called MTTF.

Reliability

The probability that a system remains operational until a
specified time. Reliability is a time-based probability
value, so it is always a value between 0 and 1. A reliability
of 0 means that a system is infinitely unreliable, or never
functioning. A reliability value of 1 indicates that a system
is infinitely reliable, or always operating.

Unavailability

The probability that, at a given time, the system would not
function, due to either a failure or a repair.

Unreliability

The probability that a failure would occur during a given
time period.

Running Markov Calculations

To calculate Markov results:

1. Select System » Calculate, or click the calculate [

button on the standard

toolbar. The Calculate window opens.

2. In the left pane, select the Calculation Selection page if it is not already

selected.

3. In the right pane, click Clear All and then select Markov to run calculations
only for the Markov module.
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4. In the left pane, expand the Markov folder if necessary and select the Reliability
Calculation page.

On this page, you specify options for evaluating reliability and availability.
For Through end time, enter 30000.
For Display results for states at time, enter 30000.

Leave the rest of the default values.

@ Reliability Calculation Options

Reliability/availability evaluation

From start time: 0
Through end time: 30000
Mumber of data points: 11
Display results for states at time: 30000
Required capadty: 100
Precision: 0.0001 -

Diagram verification

Warn on the presence of non-failed absorbing states
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8. In the left pane, select the Calculation Options page. Leave the default values.

a} Markov Calculation Options

Byailability
Capacity

Conditional failure intensity
Conditional repair intensity
Cost per unit time

Failure density

Failure frequency

Failure rate

Frequency of departures
Frequency of transitions
Frequency of visits

Mean availability

Mean capadcity

Mean cost

Mean state probability
Mean unavailability

MTEF

Mean time to failure, steady state
Mean time to first failure
MTTR.

Mumber of departures
Mumber of failures

Mumber of repairs

Mumber of transitions
Mumber of visits
Probahility

Reliability

Repair frequency

Time spent in state

Total capacity

Total cost

Total downtime

Total uptime

Unavailability

Unreliability

(5] T T T ) ) ) ) 1 T I I I

9. Click OK to run the calculations. When the calculations are complete, the View
Calculation Results window opens.

W Tlp
You can print your calculation results by clicking Print in the View
Calculation Results window. You can also save them to a Microsoft Excel
spreadsheet by clicking Excel.

10. Click Close when you have finished reviewing results.
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To display the results again at any time, you would select System » View
Calculation Results. If you have only one module enabled, the results shown are
only for this module. If multiple modules are enabled, a navigation pane is shown
so that you can select the results you want to view.

Once results have been calculated for a Markov diagram, the results calculated for
a state appear on the Results page in its Calculation Properties window. Likewise,
the results calculated for a transition appear on the Results page in its Calculation

Properties window.

Viewing a Markov Report

1. In the Project Navigator, under Reports > Markov Reports, select (Common)
Markov (Summary). The Report Properties window opens. Because the three

reports in this Report Binder file require input data, the Report Properties
window opens.

2. For the top report, do the following:
a. Under the Record selection heading, select Print selected diagram.
b. If Memory Analysis is not already selected, click I:I to select it.
c. Verify that the Apply this selection to all reports checkbox is selected.

For the other reports, you can use the default values.

3. Click OK to generate the report and open it in a preview window.

This report outputs data related to the selected Markov analysis. It includes
calculation results, state summary, and diagram.

You can use the toolbar in this window to print your report, move through its
pages, switch between a two-page and one-page view, zoom in and out, and
close this window.

4. When finished viewing the report, do one of the following to close the
window:

* Select Preview » Close.

¢ Click the close button on the toolbar.

Graphing Markov Data

1. In the Project Navigator, under Graphs > Markov Graphs , select (Common)
Markov Availability v Time to generate this graph.

If there are multiple Markov diagrams in the System file, theSelect Markov
Diagram window opens. However, this file has only one.
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The graph displays system availability at the points in time specified in the
Calculate window for Markov calculations. For this diagram, all reliability

values are 1.0.

2. When finished viewing the graph, select File » Close.

Additional Markov Features

PTC Windchill Markov includes a number of additional features and functions. A
brief listing of other topics of interest is shown below. For more information about
these features, see the help or guide for PTC Windchill Quality Solutions.

* You can specify the cost to associate with each state and transition. The cost
can be a gain or loss per unit time. Mean and total capacity and cost values can
then be calculated for the system.

* You can specify not only calculation properties but also visual properties for a
state or transition. If you want, you can even show a custom image for a state.

* You can add descriptive text labels to any state diagram. The Markov Style
Library file stores custom styles for labels, states, and transitions.
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This section of the PTC Windchill Quality Solutions Getting Started Guide
provides basic information about LCC (life cycle cost) analyses and how to
perform them using PTC Windchill LCC.

In this section, you enter a fixed cost item in the LCC module, review other cost
equation functions, and learn about using cost variables. Next, you run
calculations and view standard reports and graphs.

~ Note
Because Projects can be fully customized, your screens might not look like the
ones shown in this guide.

145



LCC Analysis Overview

LCC (life cycle cost) analysis is used to compute the cost of a product or system
over its lifetime. By including all costs such as design, production, warranty,
repair, and disposal, LCC analyses provide an accurate assessment of total system
cost.

During the system design phase, LCC analysis is valuable for determining the
most cost-effective solutions before substantial costs are incurred. It is also an
excellent method by which you can compare the costs of different alternatives,
such as redesigning an existing system versus designing a completely new system.

LCC analysis considers factors such as inflation and the time value of money to
make realistic cost computations. Such analyses can also be used to perform
sensitivity analysis so that you can pinpoint variables which have the most
influence on system cost.

If you are unfamiliar with LCC analysis and would like to study this topic in more
detail, the following text reference is an excellent resource:

» Life-Cycle Cost and Economic Analysis by Wolter J. Fabrycky and Benjamin
S. Blanchard (1991)

Getting Started with PTC Windchill LCC

If PTC Windchill Quality Solutions is started and the Tablet PC
System file is open

If you are already using PTC Windchill Quality Solutions and your Project with
the Tablet PC System file is open, you can enable the LCC module. For more
information, see Enabling PTC Windchill LCC on page 147.

If PTC Windchill Quality Solutions is not started

If PTC Windchill Quality Solutions is not started, then start it. For more
information, see Starting PTC Windchill Quality Solutions on page 10.

If your copy of the Tablet PC System file is not open

The Tablet PC System file in your My Tablet PC Project is used to demonstrate
module features in this guide. If this System file is not open, then open it by doing
one of the following:

» Ifthe Recent Files control on the Start Page lists the Tablet PC System file in
the My Tablet PC Project, click this file name to open the file.

» If the Project Navigator shows a listing of your Projects and Systems (you see
a Click a file to open link), click Tablet PC under My Tablet PC to open the
System file.
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If the Project Navigator shows that a different Project is open (you see a name
other than My Tablet PC after the Project: label):

1. Close all open files by clicking < Click to close Project >.

2. Under My Tablet PC, click Tablet PC to open the System file.

If the Project Navigator has the My Tablet PC Project open (you see Project: My
Tablet PC in the Project Navigator), click Tablet PC under the Systems heading
to open this System file.

Enabling PTC Windchill LCC

On the Module Selections toolbar, select the LCC button @ and deselect all other
module buttons.

The System file displays only PTC Windchill LCC panes.

UsingPTC Windchill LCC

The top window contains the LCC - Cost Breakdown Structure pane, and the lower
window contains the LCC - Equation Editor pane.

LCC - Cost Breakdown Structure — Displays the cost breakdown structure
defined for the system. While PTC Windchill LCC supplies some entries that
you can use as a starting point, you can customize the structure and make it as
detailed as you want.

LCC - Equation Editor — Displays the cost equation associated with the item
selected in the cost breakdown structure. You can customize all supplied
equations and create new equations.

For this example, you enter a fixed cost item, review other cost equation
functions, and learn how to insert cost variables.

Entering a Fixed Cost Item

In the LCC - Cost Breakdown Structure pane, select Maintenance Cost .

In the LCC - Equation Editor pane, review the cost equation for this item. In
this case, the cost is linked to data fields storing repair and failure results
calculated by other modules.

Select Insert » Sibling to insert a new cost item.
Enter Disposal Cost as the name of the new item.

In the LCC - Equation Editor pane, for Cost equation, enter 500 to indicate that
its costs $500 to dispose of a system.
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Reviewing Other Cost Equation Functions

Many costs might not be constant, and PTC Windchill LCC offers a number of
ways for defining how cost is computed.

1. In the LCC - Equation Editor pane, click Data Fields to open the Insert Field
window. In this window, you can insert fields from other modules in your
equation.

2. Click Cancel to close the Insert Field window.

You can also use the Data Fields Toolbar to insert fields in your equation.

3. Select LCC » Data Fields Toolbar. This toolbar, which is a fully functioning

auto-hide window, opens. From here, you can drag available fields into the
LCC - Equation Editor pane and drop them into your equation.

Click the X in the upper right corner of the Data Fields Toolbar to close it.

Click Date Functions to see the list of date-related functions available for use
in cost equations.

6. Click Math Functions to see the list of math functions that you can use in cost
equations.

Using Cost Variables

1. In the LCC - Equation Editor pane, select Variables to open the Insert Variable
window.

2. Click the Variables list to view the variables you can insert into your cost
equations.

3. Click Cancel to close the Insert Variable window.
The variables available are defined in the LCC Variables file.

You can open the sample LCC Variables file to see these variables:

1. In the Project Navigator, click Expand files to display support files.

~ Note

If this command is not available, click Collapse files and then click Expand
files.

2. Under Support Files > LCC, select Variables to open the LCC Variables file.

In the LCC Variables file, you can see the list of variables that appeared in the
list associated with the Variables button in the LCC - Equation Editor.

You can define an LCC variable to be any of the following types:
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* Constant — The value is fixed

* Varies over Time Intervals — The value changes based on time intervals
that you define, which might be monthly or yearly for example

* Varies over Alternatives — The value changes based on alternative system
designs that you define, which might be a redesign and a new design

* Varies over Alternatives and Time Intervals — The value varies based on
both time intervals and design alternatives

Select File » Close to close the LCC Variables file.
In the Project Navigator, click Collapse files to hide all support files.

Understanding LCC Calculations

PTC Windchill LCC enables you to compute costs based on the entire product
lifecycle, from inception to product disposal. One of the significant benefits of
PTC Windchill LCC is that it enables you to factor reliability metrics into
lifecycle cost, which is an often hidden, but significant, factor in overall product
lifetime cost. By accounting for component failures and repairs along with related
labor costs and maintenance activity costs, you can obtain a thorough analysis of
true product cost.

PTC Windchill LCC encompasses a variety of cost calculations.

Calculation |Description

Total system The most basic of cost computations, total system cost reflects
cost the cost of your system over its entire lifecycle by using the
cost breakdown structure of your system.

Line item Costs | PTC Windchill LCC computes the cost of each of the line
items in your cost breakdown structure. Depending upon
structure granularity, you can see the costs associated with the
various parts of your product lifecycle, such as design costs,
R&D expenses, maintenance costs, labor fees, and more.

NPV (net With the time intervals functionality of PTC Windchill LCC,
present value) |you can take into account inflation rates over the specified
time interval you want to assess. PTC Windchill LCC then
projects the NPV of your system. The NPV is the cost of your
system in today’s dollars based on inflation rates.

Costs based on | With the alternatives feature of PTC Windchill LCC, you can
design compare the costs of various design alternatives. For example,
alternatives to fix a known issue, you could look at the cost of retrofitting a
current design with a corrective action solution versus the cost
of a system redesign.
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Calculation |Description

Costs based on | Using a combination of the time intervals and alternatives
design features, you can factor in inflation rates to analyze the cost of
alternatives and |design alternatives.

inflation rates

Sensitivity PTC Windchill LCC supports sensitivity analyses, which
analyses enable you to see which variables have the most impact on

your system cost. By varying different cost items over a range
of fluctuations, you can see which variables have the most
significant influence on total cost. Ensuring highly sensitive
variables remain stable enables you to more easily keep costs
in check.

Running LCC Calculations

To calculate LCC results:

1.

Select System » Calculate, or click the calculate lEl button on the standard

toolbar. The Calculate window opens.
In the left pane, select the Calculation Selection page if it is not already
selected.

In the right pane, click Clear All and then select LCC to run calculations only
for the LCC module.

In the left pane, expand the LCC folder if necessary and select each of the

pages to view the default settings. For this example, you use the default values
for all pages.

Click OK to run the calculations. When the calculations are complete, the View
Calculation Results window opens, where you can see cost and NPV results.

¢ Tip
You can print your calculation results by clicking Print in the View
Calculation Results window. You can also save them to an Excel
spreadsheet by clicking Excel.

6. Click Close when you have finished reviewing results.

To display the results again at any time, you would select System » View
Calculation Results. If you have only one module enabled, the results shown are
only for this module. If multiple modules are enabled, a navigation pane is shown
so that you can select the results you want to view.
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Viewing an LCC Report

1.

In the Project Navigator, under Reports > LCC Reports, select (Common) LCC
to generate this report and open it in a preview window.

This report outputs the life cycle cost data from the System file, including the
cost breakdown structure items, equations, time intervals, and calculated costs
and net present values.

You can use the toolbar in this window to print your report, move through its
page, switch between a two-page and one-page view, zoom in and out, and
close this window.

When finished viewing the report, do one of the following to close the
window:

* Select Preview » Close.

*  Click the close button on the toolbar.

Graphing LCC Data

1.

In the Project Navigator, under Graphs > LCC Graphs, select (Common) LCC
Cost per Time Interval and Alternative to generate the graph.

This graph displays the cost calculation results by time interval for all
alternatives in a cylinder bar graph.

When finished viewing the graph, select File » Close.

Additional LCC Features

PTC Windchill LCC includes a number of features and functions. A brief listing
of other topics of interest is shown below. For more information about these
features, see the guide or help for PTC Windchill Quality Solutions.

You can perform sensitivity analyses, which determine how particular
variables affect overall system cost. When performing a sensitivity analysis,
you specify a variable to modify and a percentage range over which to modify
the variable. You can then view how the cost varies with the changes to the
underlying variable.

You can create very simple or complex cost equations, verifying the syntax for
equations as you enter or modify them.
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Conclusion

We hope that you have found this guide to be a useful demonstration of the
capabilities of PTC Windchill Quality Solutions. The information presented in this
guide is only the beginning of what can be accomplished with the feature-rich
power of PTC Windchill Quality Solutions.

PTC Windchill Quality Solutions customers have access to a full complement of
resources, including: PTC Windchill Quality Solutions help, getting started
guides, knowledge base articles, and experienced customer support.

You can also boost your productivity by learning from the experts at PTC
University. Whether you are looking for specific training courses, ways to
improve the proficiency of experienced users, or a personalized corporate learning
program that meets your training schedule and budget requirements, PTC
University can help you boost your productivity through online courses,
leadership training, consulting, and other services to optimize your business.

We welcome your feedback! If you are evaluating PTC Windchill Quality
Solutions, you can send email messages with suggestions, comments, questions,
and feedback of any kind to quality-tryout@ptc.com.

If you are a licensed user, you can send feedback about this guide or any other
PTC Windchill Quality Solutions guide or help system to quality-doc@ptc.com.
You can also use the many resources available for support on the Technical
Support page of the PTC website. To contact PTC Technical Support by phone,
licensed users can call 800-477-6435 and refer to the Support Phone Map for
specific menu choices. We look forward to hearing from you!
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